Nest Thermostat

 
#1

I have configured my nest account and linked it to ezbuilder. But when I try to run the sample project for Nest. I get this error Object reference not set to an instance of an object.

what am I doing wrong?

#2

Here is the full error:

Start
2: ControlCommand( "Nest", RunOnce)
> Error on line 2: Object reference not set to an instance of an object.
Done (00:00:00.8405903)

#3

There's a section of the website for tutorials. The tutorial for the nest can be found by either clicking the ? Next to the X (close) or by viewing the Activities in the learn section. Here's a direct link for the tutorial: http://www.ez-robot.com/Tutorials/Help.aspx?id=210

#4

Still not working, I must be doing something wrong.

Step 1 - Configure Nest to work with EZB. Complete - screen clip attached

Step 2 - Put ezb in client mode. see attached image.

Step 3 - Using this script.
# Update the variables with your Nest device data
ControlCommand("Nest", RunOnce)


# Speak the temperatue out of the PC speaker
say("The temperature of your home is " + $nest_temp_c + " celcius"Winky


# If you wish to speak out of the robot,
# use the SayEZB() command instead of Say()

Step 4- variables are there. see attached image.

any thoughts on what I am doing wrong

Step 5 - still getting error message.
Start
2: ControlCommand("Nest", RunOnce)
> Error on line 2: Object reference not set to an instance of an object.
Done (00:00:01.3879132)




User-inserted image

User-inserted image

User-inserted image

#5

Got it. Thanks for the help.

#6

Ok, I take that back. It is not updating the temperature and I still get the error.

#7

@dbeard
The image of your Connection control indicates you are not actually connected to the robot. Probably this just means you took the screen shot before actually connecting to the robot, but I thought I would mention it anyway since the Speech Recognition control will work regardless of whether you are connected to the robot or not. That also means it will run the script, connected or not. At least try to run it. It's possible the error you are getting could be caused by not being connected. I'm not certain of that, however.

#8

Even when connected I get the same message and it is not updating either.

#9

@dbeard
Yeah, I figured, But it was worth a shot. Sometimes the simplest things trip us up the easiest. I also note that you have to be connected in Client mode for this to work. That makes sense since only in client mode can you have access to the robot and the Internet at the same time. Heck, in Client mode I have arranged it such that I had access to the same robot from my PC and multiple mobile devices all at the same time. That could come in handy when testing a robot with in internal Mini-PC. I could have control with my desktop PC at the same time for a level of emergency control should something be amiss with the Mini-PC. But I digress.

EDIT ... I removed a paragraph about the temp. variable updating since I had forgotten you already mentioned it was not updating.

One thing I don't get is why JD calls for the Video control to be up and running in the Nest Tutorials? I don't see the relevance. But who knows?

#10

Please review attached doc.NestData.pdf