Release 2011.06.28.00

 
#1

*Warning: This version is not compatible with older .EZB project files if using Camera controls. Remove camera controls from your previous version and resave.

Updates

- EZ-B Firmware v12
- EZ-Builder 2011.06.28.00


EZ-Builder Changes

- New Window ControlCommand()s
- Added Camera Device (combines all features into one control)
- Camera tracking mode AUTO added to automatically switch between Motion and Color tracking
- Few bug fixes




  Get EZ-Builder for Windows

#2

Sweet!

BTW, on an unrelated note, I noticed the FAQs were updated to reflect that a USB BT dongle is no longer included with the EZ-B. However, on the Buy page, there is still a bullet point under Features that says "Includes PC USB Bluetooth module". I mention this because I was sad when I received my first two v3 EZ-Bs and no dongles were included...

On another unrelated note, can I defect to Canada? I'm starting to lose faith in my country...

#3

Hi,

eeek! how long should the firmware update take?

My EZ-B ver 2.1 has been sitting on this below for over 7 mins now 2nd attempt I cancelled the updater before after a similar length of time. EZ_builder now reports invalid firmware version and updater reports ver 11 still installed

Connected
Press the UPDATE button to start upgrade
Warning: Line 1: Skipping Type: 4
Warning: Line 3: Fixing Diff: 4
Warning: Line 443: Skipping Type: 4
Warning: Line 444: Impossible Diff: -7038
Address: 0x0, SB Size: 0x36FC
Starting Boot Loader...

Updating... (14,076 Bytes)

*confused*

Just got it working on the 3rd attempt no 'I am EZ-B gimmie firmware' came up 1st 2 times. Maybe a noisy bluetooth link?? I moved my Bot right next to the laptop so that might be the answer

#4

Are you certain it is using the proper COM port?

In the video, you will notice it displays text "EZ-B Reports Firmware V11" before "Connected".

User-inserted image

#5

Ok I will watch for that next time

It all works fine now and the firmware update didn't take long at all. So if you are waiting for something to appear like updating or dots across the screen indicating activity and the hardware status led isn't blinking really fast it aint happening!

#6

A noisy BT link could have been the culprit in your scenario. I updated mine last night with the EZ-B right next to my machine and it went off without a hitch. I have two more to update so maybe I'll experiment and try to update them from varying distances. I like experiments...

#7

Be careful with updating from long distances or low power. Like all firmware update bootloaders, there is never a 100% guarantee that things will go perfect Tongue ... You don't want to brick your ez-b Grin

#8

I'm an IT Manager - I defy manufacturer's recommendations for sport! Just updated the firmware on the second v3 EZ-B from about 6 meters away through one desk chair and one rocking chair. Went off without a hitch!

I should mention that I apparently fried at least 3 of the digital ports on this particular EZ-B with my little 12V reverse polarity motor controller stunt. I was hoping the new firmware would have magical healing powers... but, no dice... Maybe in v13?

#9

HAHAHA I wish! I also have a few boards with bad ADC's from oopsie's like that.

#10

Hi,

My ez-b doens't want to update...
I have tried it over and over, but it still doesn't want to update...
It says:

Attempting connection on COM40
EZ-B reports EZ-B Firmware V11
Connected
Press the UPDATE button to start upgrade
Warning: Line 1: Skipping Type: 4
Warning: Line 3: Fixing Diff: 4
Warning: Line 443: Skipping Type: 4
Warning: Line 444: Impossible Diff: -7038
Address: 0x0, SB Size: 0x36FC
Starting Boot Loader...

Updating... (14.076 Bytes)

And then it stops...
No flashing lights, only solid...
Once waited 30mins orso, but still nothing...

I'm using the internal bluetooth of my pc to connect to my ez-b, could that be the problem?
Although it works perfectly with the EZ-Builder v11.

So what can I do to solve this problem?