Having A Question With Autoposition Import

 
#1

I'm using EZ-Builder 2017.11.13.00 on Windows 10 and trying to import into an AutoPosition (non movement) control into a blank project.

I followed the steps in the tutorial and other solutions in other posts, but I'm still having a problem. Here are my steps:

1. Create a blank new project
2. Add AutoPosition(non movement) control
3. Import from example JD bare project all frames without "pause" frame
4. Click save

At this point all the frames and actions show up fine in the control, but none of the actions will cause motion when I execute them.

If I click on a different frames, the servos take no action, but if I edit the servos, I can actually move them and it shows their proper position on the JD image.

I tired importing instead to an AutoPosition contol that has movement, and I have the same problem.

Seems like a must be missing a step after importing to "activate" the actions?

Regards,
Frank

#2

Hi Frank,

I gave it a test and it works for me. Here are my steps:

1. Created a new blank project
2. Selected "Merge" (beside the Save Icon)
3. Selected the "JD Bare" Project
4. When the "Select Controls to Merge" window popped up I selected the auto-position checkbox

User-inserted image

Once connected I selected the "STAND" frame in the auto-position window and selected "Transition To". I then was able to use the JD actions as normal.

You may want to setup your own initialization script in the connection control so JD's servos can be initialized on connection. Please see the JD Example Project for details.

#3

@Jeremie, speaking of the int script, that really only runs when you create a shortcut for your project correct, otherwise it does not automatically run, you'd have to manually run it, am I right?

#4

Hi @JustinRatliff That's correct. If you don't include the init script in your connection settings then it won't run automatically

User-inserted image

#5

Well, I'll be a robot's uncle! I don't think I knew about that, or thought about that before. Thank you Jeremie!