Release 2017.01.26.00



- lowered font size of the number selector by one point to fit 125% dpi screen res when editing auto position angles

- no default ez-script when adding buttons to mobile interface. this allows Blockly or syntax editor to be displayed when editing based on user's preferences setting

- sort auto positions list in Blockly

- Blockly ControlCommand() in utility accepts multi parameters, as long as the multi parameters do not require user input (i.e. items displayed [in square brackets] mean user data.
This is displayed: ControlCommand("RGBAnimator", startAction, "Smiles")
This is not displayed: ControlCommand("RGBAnimator", startAction, [action name])

- added Goto and Label for Blockly

- changed camera grid default from 1/3 parts to 1/4

- camera grid lines save/reload

- Blockly Say is renamed to Say EZB to reflect ez-script syntax

  Get EZ-Builder for Windows


Dj, thanks for the camera grid updates !



Thanks. Hoping to get some robot time this weekend to try out this and the new mqtt plugins.



Thanks for another update with camera grids!


Just FYI, and not sure if it's just an incompatibility with my old quad-core windows 7 machine, but the update didn't work for me. The grid line fix worked but my camera wouldn't face-track at all. I used the same saved file as I was using, and went through and double checked all the settings, but the camera wouldn't track. The blue boxes never appeared on screen.
It's not a huge deal for me. I just reverted to the October 2016 release and all works great (other than the grid lines).
I had the Oct '16 install .msi on another computer but are the previous releases available on this site? I didn't see them when I looked.


Hi Mac, I don't use a camera (yet) so I may be off base with this suggestion. If you have time and the desire would you be willing to reupdate to the current version? After the update try deleting the control you're having issues with in EZ Builder and then reinstall it. See if this resolves your "no tracking" issue. I'm having similar issues with controls not responding or not being seen when called by a CC command. Our issues may not be related but you never know until you try. Winky

If this is to involved then nevermind. Smile


Hey Dave, that's a very good idea. Not too involved but I won't have time today. I'm adding a micro-servo to the camera mount so the camera can be adjusted up and down. I forget sometimes that not every human being isn't exactly my height, lol. I think I panicked a little when it didn't work. I've had iRobot shut down for a couple weeks and thought maybe something happened.
I'll take another stab at it tomorrow after school.



Good luck Mac. I'm very interested but no hurry. Winky


@Dave I reinstalled the new release (although not the one from the other day) and deleted the camera control. Opened a new control, reset all the parameters and scripts, but I'm afraid it still doesn't track with the new release. I'm not getting any blue boxes around my face and neither servo moves. I tried color tracking and it works for a second, I get the blue box for a second, and then the "color" check box unchecks itself.
But it still works great with last October's release. And having the micro-servo on the camera for vertical detection made a huge difference. iRobot's head is on a tilt so it sees at different heights as it tracks left to right.
I hope this helps you a little. Sorry it took a couple of days. School has been very demanding already.


Please review the other thread that you have this experience mentioned in, because I have a response regarding new features and settings that you may require to tweak.