All Tutorials / DJ Sures / How To Make An EZ-Builder Plugin

How To Make An EZ-Builder Plugin

Trouble Shooting

This is a list of trouble shooting conversations with solutions from the EZ-Robot Community Forum regarding creating plugins...

Blank Space In GUID Folder Name
http://www.ez-robot.com/Community/Forum/Thread?threadId=8440

Plugin.XML Not Copying to Output Folder
http://www.ez-robot.com/Community/Forum/Thread?threadId=8440

Plugin.XML file with invalid characters produces error
http://www.ez-robot.com/Community/Forum/Thread?threadId=8993

Here are some items to verify that you may have overlooked during the previous tutorial steps. Please check that these steps have been taken:

1) Have the EZ-Builder and EZ_B references been added and configured for "not to copy"?

2) Is the Output Folder of the plugin specified to the correct location? (i.e. c:\users\public\documents\ez-builder\plugins\)

3) Is the plugin.xml configured to be copied to the output folder? Setting should be set for "Copy Always" in solution explorer properties.

4) Is the latest version of EZ-Builder installed?

5) Is the main form of your plugin inheriting the correct pluginMaster class rather than Form class?

6) If you cannot execute the plugin for debugging, is the "Debug With External Application" configured to use EZ-Builder.exe?

7) Is the correct DLL filename of your plugin specified in the plugin.xml file?

8) Is the correct GUID specified in the plugin.xml file?

To verify any of these questions, revisit the tutorial steps to ensure that you have completed the tutorial entirely.