Revolution Roli

Connecting & Troubleshooting

Introduction

wifi.png

This tutorial explains how to connect to the EZ-B v4 from your Windows PC. This is a generic connection tutorial and not specific to any robots. There are specific connection tutorials for each style of robot by clicking here. However, for connecting issues, use this tutorial.


Anti Virus

Antivirus Software - This is the number one connectionn issue. There are many reports of connection issues with PCs running Antivirus Software, such as AVAST, McAfee, Norton or Norton Internet Security. If your PC has Antivirus software installed, please disable or uninstall it. Nearly all of the communication issues are related to anti-virus software, such as Norton or McAfee. Simply disable the virus scanner before contacting EZ-Robot support.


How To Connect via Wi-Fi



Wi-Fi Connection Mode

The default EZ-B v4 Wi-Fi setting is AP Mode (also called Wi-Fi Access Point or AdHoc). Tutorials on how to change the WiFi mode can be accessed HERE.



Developer Kit Users

If you have a developer kit and the EZ-B is disconnecting, chances are that the batteries are not providing enough current for the servos. When this happens, it is called a "Brown Out". That means the EZ-B controller is not getting enough power when the servos move. In this case, the only solution is to replace the power source with higher amperage. A wall-wart (power adapter) will not provide enough current for electro-mechanical servo motors. The ideal option is to purchase a LiPo Battery, Balance Charger, and LiPo Battery Harness. If you're convinced to use an adapter for power, there are also 2 great tutorials created by EZ-Robot users HERE and HERE.



Trouble Shooting Connection Guide

If you are still having trouble connecting to the EZ-B v4, this section below contains trouble shooting steps. If you are ready to post on the forum requesting assistance with connection issues, it is mandatory that you follow this exercise first. When you post on the forum, please provide answers to the following questions so someone can better understand the situation to assist.


  1. What EZ-Robot or product are you using? (i.e. JD, Six, Developer Kit, etc).

  2. Is the battery on the robot fully charged?

  3. Does the robot make a startup sound when powered on? Is there a verbal message spoken from the EZ-B v4? If so, you may need to reset The EZ-B v4

  4. What color is the light on the EZ-B v4 and is it flashing or steady? (Flashing Green, steady blue, white, etc)

  5. Are you connecting the device to the WiFi network of the EZ-B v4 by following the video instructions on this page?

  6. What error message is displayed in the status window at the bottom of EZ-Builder? Press the COPY button on the status window and paste the contents in the forum post.

    • If an error appears, some devices take up to 1 minute to detect the ezb - wait 5-10 seconds and press connect again.
    • Note: do not change or modify the IP address field on connection screen. Use the default value.

  7. If a connection still does not occur, are you certain your device is connected to the EZ-B v4 via Wi-Fi?

  8. Have you double checked the wire connections to the EZ-B v4 using the very helpful learn section on our website? Ensuring the black wire if all plugs matches the black side of the ezb connections? Etc...

  9. Reset the EZ-B and repeat this procedure if you are still experiencing issues.

    • Resetting tutorial can be found here
    • When resetting, does EZ-B speak introduction message as in the video?

  10. If still unable to connect, inquire on the Community Forum and paste answers to these above questions. Also provide what device is being used to connect to the EZ-Robot? (model/operating system) eg Windows 8/Samsung Note 3/Android, iPhone 6, etc


Continue to Next lesson

Last updated 2/28/2017

Table of Contents




2. Blockly