Award
Congratulations CochranRobotics, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Windows 8 Speech Synthesis And Ez Builder Question

Assistance Requested

Help Steve G with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

Steve G claims to have checked these sources:
 
#1

Hey guys.

I have asked this question in another thread, but I decided to create a new "assistance required" thread as my issue relates to Windows 8, where as the other thread was really related to Windows 7, plus I'm still having problems. I really hope someone can help with this.

The issue

I'm in the middle of a transition from moving from a Win 7 to Win 8 laptop, and I'm having a real pain in the butt issue using speech synthesis voices with the new Windows 8 machine and new EZ-Builder install.

As Richard may remember, I mentioned in the other thread that I copied the .exe file for a Cepstral voice from my Win 7 machine, reinstalled it on to the Win 8 laptop, and added the activation key. The voice worked on Narrator and other 3rd party apps such as screen readers, but it never worked on EZ Builder so I thought that was the problem. I have since reset the laptop back to the "Out of the box" state, and started again.

My new Windows 8 Toshiba Satellite laptop comes with three pre-installed voices, but only one of them works with EZ Builder. I have installed a fresh version of a trial Cepstral voice and a 30 day trial of an Ivona voice, and neither one works with EZ-Builder either.

I have tried each and every variation of the "Speech synthesis" settings for each voice and they have made no difference whatsoever, and keeps using the one Windows voice. The only thing that does change is the "Rate".

Have any of you guy's faced this issue with Windows 8, and/or does anyone know what can be done so I can use the voices I want to use? I really want to get this working and I don't see why I'm having these problems, as using Cepstral with EZ Builder on Windows 7 was no problem at all. Please help. *confused*

Many thanks.

Steve. Smile

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

@Steve... so within ez builder if you set the voice to be the voice from Cepstral it still speaks in the default Windows built in voices?

#3

Yeah that's right. I can change it to Cepstral, Ivona, Windows #2 voice, or Windows #3 voice within speech settings, but keeps using Windows #1 voice, even changing Gender, Age or Emphasis to any variation of settings doesn't change this.

#4

@Steve.... Wish I could help you more.... I have one of Ceraproc's voices on 2 of my win8 machines... I have no issues going back and forth with any of the voices... including the default Windows voices... Sorry I couldn't be more help dude...

#5

No worries Richard. I appreciate your input never the less Smile. I just hope someone else will chime in with a solution or some advice. I'm sure I'm not the only one who has faced this, and if I am, then maybe it's something to do with the new laptop (which I don't think it is).

If it was just the 3rd party voices not working I could kind of understand it to some degree, but the fact EZ Builder is not using two of the three pre-installed Microsoft voices is baffling.

#6

Just a thought... Do you have the option of installing your Cepstral voice as administrative?... Right click the file and select Run Via Administrative? A while back I had Paul (Cepstral voice) and I can't really recall but I vaguely remember having to do something like run as administrative or run in Win 7 compatible mode or something like that in order to get it to work....

I am probably way, way off so I wouldn't hold your breath.... Worth a check, maybe?

#7

Ok thanks dude. It's worth a look as I will try anything at this point. Still, that wouldn't explane why the Ivona and two Microsoft voices are not working.

#8

Ooops. you're right forgot about that.... What happens if you go into Windows settings and set your Cepstral voice as window's default voice?

#9

No difference. Other system or third party apps will use whatever voice I select, (Cepstral for example), but EZ Builder will still refuse to use it.

#10

That so is weird... I assume you've uninstalled ez builder then downloaded a fresh copy and then reinstalled it....?