Switch On H-bridge?

 
#1

Hi,

On the 2.5A Motor Controller that is sold on the EZ-Robot store, there is a pushbutton switch labeled "S1". It seems to toggle an LED that is labeled "5V Power". What does this switch actually do?

Thanks,
Mike

#2

It turns on and off the on board voltage regulator. If you have external power running your motor you don't need a battery pack attached.

If you have external power Unplug from EZ-B. It should still be powered up depending how the button is. Push it up and down, if light comes on then it's on external power. Should be pushed down for batteries (I think).

#3

Thanks very much for the reply, but I don't understand your advice.

I am using an 11.4V battery connected to Vcc and ground on the controller board. What position should that switch be in? And what does it do?

I have a separate 7.6V battery connected to the EZ-B. I also wired +5V from the EZ-B to the "5V" input on the controller board. I assume this is the reference voltage for the logic on that board.

#4

No worries, these things are confusing at first.

Usually H-Bridges are capable of running motors at different voltages other then what the voltage is that's supplied to the board to power it's CPU. So you would have one voltage (in this case 5vdc) to power the h-bridge's CPU and a different voltage to supply the motors. This way you can run motors at, lets say 24vdc or any other DC voltage as long as that voltage is within the specs of the H-bridge. EZ Robots's H-Bridge controller CPU will takes 5 volts, and the motors can take up to 46 volts. Peak current for the motor supply side is 4 Amps. In the following picture both the VCC (Motor supply voltage and the 5vdc (H-Bridge supply voltage) are tied together to the + side of the battery pack:

User-inserted image

This way it will only give your motors 5vdc. If you have motors needing more juice then you separate the VCC from the 5vdc and run your higher (or lower) voltage to the VCC lug. Important: Run both neutrals (-) to the Ground lug. Almost always tie your neutrals together unless your trying to fix a electronic noise problem in your sound system.

Now to your question; if your running a motor supply voltage to the VCC then you don't need a separate 5vcd supply (in this case the battery pack). Leave that off and move the button you asked about into the "up" possession. This will connect the On Board voltage regulator and supply the CPU with the needed 5vdc from the VCC instead of using the battery pack.

Of course if you like you can use two different power supply voltages and move the button into the "down" possession and disconnect the voltage regulator. This is handy if your motors have a big current draw or your motor power supply is just strong enough to push the motors. A second 5vdc supply to the CPU will keep it's voltage needs smooth and trouble free.

Note: I could be wrong about the "Up and "Down" possessions. If so, just reverse what I said.

One last thing. With large motors you need to be concerned with "Fly Back" voltage. That's when a DC motor suddenly reverses direction and the magnetic field collapses sending a voltage spike back into your control circuit. It can sometimes reach twice the amp's you were drawing to run the motor. So if your drawing 3 amps to run your motors and suddenly reverse you could be slamming up to 6 amps back into your h-bridge. This will burn out your H-Bridge. A set of fast switching diodes to draw that extra voltage to ground is the best way to protect your h-bridge. Even better, buy an H-Bridge that has good over voltage protection. Pololu.com has some nice ones. If you are just running small motors pulling less then 1.5 amps then you will not need to worry about Fly back voltage with the H-Bridge EZ Robots sells.

Hope this clears it up. Winky

Happy building and have fun!
Dave Schulpius

#5

Thanks Dave. That was very useful. It is nice of you to take the time to explain the details.

When the red LED that is labeled "5V Power" is illuminated, does that mean that the Vcc supply is being used to supply the +5V thru the regulator or that the external +5V connection is being used?

#6

Where it said motor 1 and motor 2 in the picture you just have to put the motor inside it or I am I doing all wrong

#7

I've covered this H-Bridge wiring in a tutorial and gone pretty in depth too, including photos of the wiring. Click here