"unable To Load" Error When Loading Plugin

 
#1

I have tried two different Windows 10 laptops with all updates and I'm using EZ-Builder 2017.01.17.00

When I try to install & open the "servo recorder" plugin, or any plugin I've tried, I the error shown in the attached snap

User-inserted image

I'm starting with an empty project, nothing added at this point

I couldn't find any posts on this issue

Regards,
Frank

#2

I think you have assigned the plugin file to be connected with EZ-Builder. The plugin file are files with extension *.ezplugin are registered with the plugin manager "EZ-Builder plugin Manager.exe".

Plugins are added to a project via ADD CONTROL button. They are not added to a project by double clicking on them in the file explorer.

What you have done is downloaded a plugin file. Then you double clicked on the file and selected EZ-Builder to open it. What you should have done is let the plugin manager install the file for you.

So now the file association is to the wrong program.

To resolve this issue on your computer, you must re-create the association with .ezplugin to "EZ-Builder plugin Manager.exe" not "EZ-Builder.exe"

#3

Here are step by step details on how to add a plugin (or any control) to your project...


1) Load EZ-Builder
User-inserted image

2) Press PROJECT -> ADD CONTROL
User-inserted image

3) The list of controls sorted by category tabs will be displayed
User-inserted image

4) Choose any tab that has a control that you wish to add to the project. For plugins, they are listed both in their specified category tab and all the plugins tab. plugins exist in both tabs for convenience
User-inserted image

#4

@DJSures
.... that solved my problem. I was using EZbuilder to try to load it. I wasn't aware of the plugin manager

Thanks,
Frank

#5

1) To repair the association, locate the *.EZPLUGIN file and right click, select OPEN WITH
User-inserted image

2) It should default to the plugin MANAGER. If it does not, select the MORE APPS button
User-inserted image

3) You're going to want to make sure the checkbox "ALWAYS USE THIS APP..." is checked

4) Now you have to navigate through the list to find the EZ plugin MANAGER. If you find it, make sure the checkbox is checked
User-inserted image

5) If you don't find the plugin manager, you'll have to navigate to it. Select to locate the program. Make sure the checkbox is checked
User-inserted image


The idea here is to ensure the checkbox is checked and the .ezplugin file is now associated with...
User-inserted image

#6

Thanks for the detailed reply

Very comprehensive

#7

I try Grin to be very thorough

Helps for future searches just in case it happens to someone else one day