Mobile Camera Control - Y Axis

 
#1

Hi guys,
I'v been writing my mobile app for iRobot and everything works great. However, since I had to mount the camera upside down I have to flip the Y axis in the camera control in EZ Builder (rotate none flip Y). But that doesn't seem to translate into the mobile app, leaving me with an upside down image on the screen. Not great for face-tracking, lol.
What am I missing *confused*
User-inserted image

#2

Oh, I almost forgot, Happy New year!

#3

I believe the mobile camera control does not have the ability to flip the image. Mobile has quite a few differences than the windows version.

I can look into it for the next update.

Happy new year to you as well Smile

#4

Thanks DJ. Yes, please do look in to it for the next update, if it's not too much trouble. I could try flipping the camera upright but it won't look as natural.


User-inserted image

#5

Can you move the camera to the lower edge of the picture frame? That would flip the camera around.

#6

The latest version supports the flip value from the windows camera device setting. The version is 2016.12.31.00, wait for it to be available here for your Android device: https://play.google.com/store/apps/details?id=com.ez_robot.ez_builder

iOS will take time until apple review process is complete.

#7

Dave, originally the camera was to be mounted to the bottom of the tablet where it might have been less obvious. Then I remembered the tablet actually needs the charging cable attached, lol. I thought about embedding it into the forehead of the face but feared it would overheat. I don't mind it on the top; half the point of this sculpture is showcasing the gadgets.

DJ, you da man! Thank you for updating the app so quickly. You folks in Canada sure know customer service. Have room up there for a bookseller and art teacher?

User-inserted image

#8

It was just a thought and suggestion. I'm glad DJ was able to help by adding this feature for you and others who follow.

#9

All thoughts and suggestions welcome at all times. I appreciate your input, Dave. Smile

#10

Update:
The new version of EZ-Builder Mobile does, indeed, have the camera flip control and works well. However, I'm unable to get the camera to face-track (I haven't tried other types of tracking yet). The camera connects fine and shows the image, my "connect" and "center servo" buttons, along with my "servo slider" work very well, just no camera tracking.
I tried rewriting the mobile app with nothing but the "connect" button and the camera but still nothing.
I don't think it's any of my devices (laptop, tablet, etc.) since I did have my setup tracking with a simple app with the camera mounted on top of a servo (before it was installed in the sculpture).

BTW, Dave S. and DJ: the script for initial servo settings (speed and position and servo limits) you both shared work great and translate into the mobile app. Thank you.

Hmm, I haven't updated the windows Builder in a while. Maybe I'll try that.