New Roli Battery Dead

 
#1

Hi I just got the new Roli and it worked ok after I fixed the H bridge broken wire and had a new servo shipped to me to replace the bad one, however now the charger flashes all 3 lights red when I try to charge it (no I did not let the battery totally drain). I have a second charger and it does the same thing. Next I plugged the chargers into another battery I have and it charged just fine. My question is this new battery toast or can it be resurrected.

#2

How many times is it flashing? The manual that came with the charger explains the codes.

Alan

#3

I read the manual, it does not diagnosis this problem. As for the light they are continuous

#4

Did you check the User manual page 2:

User-inserted image


If leds glow red (continuous) the charger is charging.
if the leds flash x1, x2, x4, x6 is an error.

Can you confirm ?

#5

Depending on the version of your charger, the battery tutorial with diagnostic info is here: http://www.ez-robot.com/Tutorials/Lesson/26?courseId=3

I see your roli was charged and operational on the 14th starting at 8.2v and shut down at 7.2v. The battery was charged and used again on the 18th, starting at 8.2v and shut down at 7.2v.

That is within correct operating voltages of the battery, so there should not be any damage to it. The charger is quite sensitive and in this case may be providing a false positive error.

Let us know what that error is and it will help to identify next steps.

Also, please update EZ-Builder to the most recent version.

#6

The Roli on thoses dates was running on my second battery pack i have, I checked everthing and found that the battery is shot. No biggy it happens with these batteries, chargers are all working ok i used them to charge up other batteries I have.

#7

If the battery is reporting unbalanced (6 flashes, stop, 6 more flashes), it is sometimes possible to force them to balance either using a "dumb" charger, or (and you need to really use caution here) hooking up something that drains just one cell instead of both cells until they are at the same discharge rate.

However, that may not be worth the risk. 2S lipo's are not that expensive, as you pointed out. Shipping charge from EZR is more than the battery, but in the US, you should be able to get an equivalent at any decent hobby shop or from Robotshop or Hobbyking.

Alan

#8

Thanks for the help everyone, I'm just going to use my backup, order a new one, and Poop Can this battery.

#9

I bought a new battery it has been resolved