Soundboard Not Triggering In Mobile App

 
#1

Greetings everyone!

I have a script that triggers my soundboard in EZ Builder (Windows) but it does not trigger when I am in the mobile app. Now the mobile app is able to trigger sounds when I access the sound file directly from the soundcard in the control list but as soon as I go back to the mobile app and execute the script nothing plays.

Any suggestions? Is there a special script that I don't know about? This is only a problem in the mobile app. When I run the mobile interface from my desktop everything is fine. In the past, the sound file wouldn't transfer to my iPhone but now it does because it is playable in the control list. It's like the EZB knows it's there but doesn't want to play it as part of the script assigned to the button.

EDIT:
It is important to note that I am using a Bluetooth speaker instead of the EZB speaker to play the sounds. If I disconnect the BT speaker the sounds DO NOT play over the EZB speaker. However, when the BT speaker is connected the soundcard control is able to play the sound directly from the control list. The EZB speaker is not able to trigger in any form, control list or otherwise. I never uploaded the sounds into my iPhone. They seem to have come over with the mobile app update.

Thank you,

Douglas *confused* *confused* *confused* *confused*

#2

There are two sound board types...

- SoundBoard (PC) will come out of the speaker of the mobile device
- SoundBoard (EZB) will come out of the speaker of the ez-b

You can share your project for me to review if you'd like

#3

Thank you DJ!

FYI - I just upgraded the com board today to v2.

I'll open up the app for you to play with. I've got a sound script on the Freak Out button that I need to execute with the Autoposition Script. Ideally I want it to play through the Bluetooth Speaker linked to my iPhone during execution.

On another note, I honestly can't believe the CEO is going to take a look at this. Wish other CEOs were as available as you!

Sincerely,

Doug

#4
#5

Hi DJ,

I also just noticed that the buttons with soundboard scripts do not function. If I remove the soundboard script from the button, then the autoposition script executes.

I need R2 to play sounds when he is animated. The sound works great through the direct control list on my iPhone; it plays the sound file through the Bluetooth speaker paired to the iPhone. However, when I jump to the mobile interface and start pushing buttons, it doesn't know what to do.

It's like the mobile interface is getting hung up on the soundboard script so it just doesn't execute the rest of the program in addition to not knowing where to send the mp3.

Thanks again for looking at this!

Sincerely,

Doug

#6

no problem Smile I'll get back to you tomorrow afternoon. I don't bring my laptop home anymore so I can have a little bit of a life these days

#7

Ps, is this for android or iOS?

#8

It's for iOS.

Thank you so much!

#9

You're attempting to play the audio twice. Once in the FREAK OUT button and again in the FAST CONSTANT WAVE action. See images below...


User-inserted image

User-inserted image

#10

Thank you for finding that DJ! I made the edit and removed the soundboard script from the Fast Constant Wave Action but there was no difference.

The Soundboard control still executes the sound file within the Control List (on my iPhone) in the mobile application but it still doesn't execute the sound file upon pressing the Freak Out button (on the iPhone). If I press the Freak Out Button on my PC's desktop Mobile Interface it works perfectly, just not when I use the Mobile Interface on the iPhone.

Any ideas?