Award
Congratulations DJ Sures, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Shaking And Confusing Rotationservos Makes Me Grazy

Assistance Requested

Help Stiko with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

Stiko claims to have checked these sources:
 
#1

I bought 4 brandnew rotationserver.
One starts at 90 ° and is only 90 ° mobile.
Even when creating a servo profile -90 ° it is only 90 ° usable.
Another starts to shake after 2 minutes.
It shakes back and forth between 30 and 90 °.
I tried different pin.
The servoprofil is ok.
2 Servo function properly.

I have make the lessons about servo and servoprofiles.
And i have make all lessons about EZB

Can I disassemble the servo and repair or are this garbage.
These are new and were not overloaded.

Greetings

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

Maybe I am not understanding your problem but servos are from 1 to 180deg.... 90 is centre... 1 is 90deg one way and 180 is 90deg the opposite way... -90 is not a valid servo position... Also what are you using to power the servos? Did you say other servos are working fine?

#3

1) are these ezrobot servos? If not, aftermarket servos may shake and behave strangely due to 7.4v battery supply. ezrobot servos are properly designed for use in robotics unlike traditional hobby servos.

2) when creating servo profile, a warning message will display if the adjustment value is more than 10 (I believe). That warning message states that the bracket must be calibrated. This involves using a philips screw driver and repositioning the bracket using the single screw holding it on. You can find out more here for lever servos: http://www.ez-robot.com/Tutorials/Lesson/25?courseId=1

Otherwise, locate your appropriate robot tutorial in the learn section and view the calibration procedure related to that robot.

#4

I use everything original EZ Robot accessories.
I got everything new yesterday.
All servos are used on the JD.
This is really annoying.

#5

@Stiko Are you using your own ez-scripts or just a simple servo control to move the servos?

#6

1) What robot do you have? The usage log says you have been loading JD.EZB project. The JD robot does not use Rotation HDD Servo-motor. Can you expand on what the Rotation HDD Servo-motor is doing with the JD? Also, what ports do you have the Rotation HDD Servo-motor connected to?

2) What other items are connected to the EZ-B v4/2 Wi-Fi Robot Controller?

3) Can you share your robot project?

#7

My Order was 11-8354
November 10, 2016 - 2:41:37 PM
Yesterday was coming my order per DHL express.

I use a JD Robot set with 2 wheels and 2 rotationserver for the gripper.

I think wheels are better for take some stuff.

http://www.bilder-hochladen.net/i/d7mo-gs-cf63.jpg

I just wanted to make a video with the 180 ° servo, which remains in the middle,
This does not rotate anymore and only makes noises.
The other servo shakes all the time.

I hope you can now understand my frustration.

2 Servos working perfect with my order.

I have make 2 Videos.


https://youtu.be/wGF1Kg36mCA

#8

Thank you for the video - the servos are clearly moving.

1) Please share your robot project. You can do so by either ATTACH FILE or SAVE to EZ-Cloud. Either way will work Smile

I will verify the project is not re-using ports that may be used elsewhere.

2) To clarify, there are 3 rotation servos in total. 2 rotation servos are okay, and 1 rotation servo vibrates. Is this correct?

#9

I have buy a " 3 peace arm with gripper" include a rotationservo and
the "3 rotationservos" in a package.
So i have
4 rotationservo
in my order and 2 in the shoulder from JD. ;-)

2 works normal
1 shake and
1 run free

This is my project.
http://www.ez-robot.com/Community/EZCloud/RobotAppDetails.aspx?id=4036
But its not complete. I need a lot of time i think. ;-)

#10

I made some changes to your project, which will not affect the servo issue. I believe the servos may be damaged. Contact Us and reference the URL of this thread to initiate a warranty claim. They might ask to have the servos sent to us so we can see what happened for quality control.

As for your project, here's some changes i made to help you along..

1) Using an Auto Position (no movement) control instead of Movement

2) Added Continuous Rotation Servo Movement Panel (i "guessed" the direction, you may need to edit the configuration if the directions are reversed)

3) Removed empty controls (empty soundboard, Com Port Manager)

4) Added a horizontal slide for the D14 torso servo (may be reversed, the invert option can be used to fix that because i had to guess)

5) Removed servo limits for humanoid ankle ports which are no longer used in INIT script

I recommend viewing the init script to ensure the ports and limits and speeds are correct.

Here's the project: FlexDJEdits.EZB