Trex Motor Controller Problems With Ezb

 
#1

I have several Pololu TReX motor controllers laying around. I hooked it up and connected a motor and a linear actuator to both channels. I started with an standard RC controller and made sure it was all set up. Worked fine.

Then I replaced the reciever with the EZB. It worked for about 10 seconds then stopped. I had used PWM slider, then I tried servo etc. Nothing would work again. The green LED on the TReX flashes when there is no recieved signal. It was flashing. So I replugged the RC set up and it all worked fine again. Then again with the EZB, this time only one channel worked for about 10 seconds then nothing. I could not get it to work again after that. Anybody tell me why the EZB will not send thru a simple PWM that the TReX expects to receive? Or how to keep it connected?!

Thanks!

Will

#2

@fxrtst PWM is Pulse Width Module, not for servos. It's a method of outputting a range of voltage from the digital I/O pins.

The motor controller would require a Servo connection, not PWM.

And even more specifically, you would use a Modified Servo Control. If you have two connections on the motor controller, then use a Modified Servo Movement Panel.

You can use the Tutorials section to read about how a servo works. It's a bit differnet to wrap your head around - but once you do, it'll be a breeze

#3

OK I'll try again tomorrow. This particiular motor controller uses standard R/C reciever and transmitter out of the box. Just connect up power (in this case 12 v) to the TReX and both (+)(-) leads to motor 1 and motor 2. The final connections use Standard Servo connections and cables for the signals to motor 1 and motor 2. So I will try the Modified Servol control in the moring and see if that sends the right signal the controller is looking for.

Thanks

Will

You connect servo wires to the first two connnections on the left side for M1 and M2


User-inserted image

#4

OK had a bit of time to test this morning. Results were: Modified Servo does not seem to work at all. Only PWM works some of the time. When it loses signal, I can sometimes regain signal by turning them to off (Stop) they will sometimes begin to operate again. I even tried swapping out power supply to the TReX thinking it was browning out. Same results as before. Anybody have any ideas?

I have included the following videos:

1) The setup running with just R/C
Click To Watch Video


2) The set up with EZB when it loses the signal.
Click To Watch Video


3) Set up trying to use the Modified Servo panel
Click To Watch Video


Please excuse all the hammering. There is construction next door.


Cheers,

Will Huff

#5

Remove PWM from your memory Smile Pretend it doesn't exist. You don't want to use PWM, never use it for what you are doing.

Either the Modified Servo Movement Panel or Modified Servo Control will work, you'll need to adjust the settings under CONFIG. The Forward and Reverse settings will need to be configured.

The best way to test to find the right settings is to first use a Vertical Servo Control. Then start slowly moving the values until the motor begins to move one direction. Write down that value. (that'll probably be reverse value)

Then continue to move the slider until the motor stops.. Write down that value (that'll be the stop value)

Then continue to move the slider until the motor starts, but keep moving it until it's at full speed before it stops again. (That will be the maximum speed forward value probably)

Then add those values into the Modified Movement Servo Panel

However, once you upgrade to 15.3, you'll have to do that process again becuase the servo values have changed Smile - for the good!

#6

Hahaha. "Will put down the pwm and walk away". Ok I will give the servo a spin again and work thru the values see it works. Excellent point when 15.3 comes out. I'll make sure not to do too much building until then!

Thanks again I'll let you know how it goes.

Will

#7

HHHmmm. Well I end up with the same problems. First 4 attempts the servo panel did not control the motors. There was no response at all as i moved the slider slowly from 1 to 70 on both channels. The TReX signal light just sat there and blinked. Then finally without warning, both channels began to work at the same time and then after about a minute, the TRex began to blink again, showing that the signal had been lost. I could no longer reconnect to the channels. I did manage to grab the max forward and reverse numbers for both channels, but as soon as i opened a Modified Servo panel and input the numbers it stopped working after a few seconds.

I guess for what ever the reason the TReX is not compatable with EZB.
I certainly gave it the ole one, two.

Thanks for all the help though.


Cheers,


Will

#8

If the treks accepts a r/c servo signal, than it is 100% compatible with the ez-b. the ezb has a wider range of servo signal pulses to accomodiate for all servo brands and models. Most of these motor controllers require a specific range, otherwise they'll not work.

Because these things, like the trek are programmable (in a sense) by learning their limits (sometimes) its a bit more difficult to configure. So don't think it's not compatible, I assure you it is Smile instead continue thinking it requires a specific configuration. Because I do not own one of these, I'm not able to get the configuration for you. Once you do find the proper values, make sure you post them here so we can share with others.

Smile

#9

Also Make sure the treks is configured for r/c mode by the jumper

#10

TReX is in R/C mode as video 1 demonstrated above. I am thinking that the linear actuator may be messing things up. As everytime I activate it is when I lose signal. I am going to remove it and use another 12 v motor I have. Then I'll input the range values I extracted and try again. Let you know how it goes.

Worst case if it still works erratically I can send you a TReX to test on and see what your results are. If you could send it back Smile when done.

Again thanks for all the help.


Will