Batteries Not Charging

 
#1

I have plugged the battery in to charge multiple times following instructions, and it always flashes red. I can't tell what's wrong and the bot won't even turn on after leaving it plugged in for a few minutes. Not sure how to fix it.

#2

The battery care and charging tutorial can be found here: http://www.ez-robot.com/Tutorials/Lesson/26

#3

I used the instructions in the tutorial, as I said.

#4

Visit this tutorial http://www.ez-robot.com/Tutorials/Lesson/26 as previously stated to identify the error code from the charger of the condition of the batteries. Additionally, information in the tutorial may provide battery recovery steps with a smart charger.

#5

I have identified the error code, in the tutorial. I meant that I couldn't find what was causing it, not that I didn't know what was wrong.

#6

Glad I can help! The learn section is always the best place to look for information.

#7

I still haven't figured out how to fix it, though.

#8

The error code for the charger can be viewed on the previously mentioned tutorial page: http://www.ez-robot.com/Tutorials/Lesson/26

If you locate the version of the charger on the tutorial page, there is a chart that explains the error codes. If you have an error code on the charger (flashing leds), the error code will be visible on that page.

Some errors can be fixed by using a smart charger and others require a battery replacement.

Batteries are damaged by the reasons listed on the tutorial page: http://www.ez-robot.com/Tutorials/Lesson/26

When a battery is damaged, it may not be recoverable and the ez-robot charger will present an error to notify you of the error.

#9

The error code is for bad connection, and it isn't mentioned how to solve it.

#10

Are you using an ez-robot product? There is no error labelled "bad connection" in the manual link that i have been providing. If you are using an ez-robot product with an ez-robot charger, this page will help you diagnose the charging issues with ez-robot battery on an ez-robot charger: http://www.ez-robot.com/Tutorials/Lesson/26

If you are using an ez-robot product, please tell me the LED error code. You can find it by reviewing the link that i have been sending.