Award
Congratulations thetechguru, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

I Cannot Create A New Project In Ez-builder

Assistance Requested

Help Mickey666Maus with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

Mickey666Maus claims to have checked these sources:
 
#1

Hey guys,
Something very strange is happening over here...I just cannot create a new project.
Once I go to file/new/new project and add a servo I cannot use this newly created servo!
I can center it once or move it once, but then it stops responding!

The EZ-B still works a is connected to the Wifi

I installed the latest version of EZ-Builder

If I open an old project it all works normal, I can also add new servos to other ports and delete existing ones and address freshly created servo Movement Panels to those same ports without any problem!

So I can use EZ-Builder, no big deal...I just have to open old projects, delete all the stuff that I do not need and it all works fine.

But it kind of bugs me...has anyone ever experienced something like this before? *confused*

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

The EZ-Builder instance is disconnecting from the EZ-B. This is most likely due to a brown-out following the attempt of moving the servo. What power source are you using? I believe the power source may be less than 7.4v because you also have the battery monitor disabled - which also may not be enough to move the servo.

Disconnect message from your status window:


25.09.2016 20:10:50C:\Users\swann\OneDrive\Dokumente\EZ-Builder\My Projects\PWM_Arm.EZBComm Err: System.IO.IOException: Von der bertragungsverbindung knnen keine Daten gelesen werden: Ein Verbindungsversuch ist fehlgeschlagen, da die Gegenstelle nach einer bestimmten Zeitspanne nicht richtig reagiert hat, oder die hergestellte Verbindung war fehlerhaft, da der verbundene Host nicht reagiert hat. ---> System.Net.Sockets.SocketException: Ein Verbindungsversuch ist fehlgeschlagen, da die Gegenstelle nach einer bestimmten Zeitspanne nicht richtig reagiert hat, oder die hergestellte Verbindung war fehlerhaft, da der verbundene Host nicht reagiert hat
bei System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)
bei System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
--- Ende der internen Ausnahmestapelberwachung ---
bei System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
bei EZ_B.EZB.RdxFZHO1y2(Int32 , Byte[] cmdData)


The battery monitor disable message that you are receiving:

25.09.2016 20:10:38C:\Users\swann\OneDrive\Dokumente\EZ-Builder\My Projects\PWM_Arm.EZB**WARNING: The low battery warning monitor is set DISABLED. If using the LiPo batteries from a Revolution EZ-Robot, for battery longevity and your safety we highly recommend that you re-enable the battery monitor. This setting can be found in the Connection Control Config Menu.

#3

Thanks for the quick response...I actually used my low amp power supply, because I was just having a single servo attached! I will check this right now! Winky

#4

Wicked Grin

A single servo can draw many amps - surprisingly! It's the surge of movement which causes the consumption.

#5

It still happens...It's really weird!

If I close EZ-Builder and load an old project it works just fine!
If I try to create a new project the servo does not move...

I am using a 5V/20Amp Power Supply and the EZ-B is not browning out...

#6

And you set the MIN and MAX positions of the servo? And the EZ-B index is specified correctly?

#7

Yes it is set to board zero, it connects without a problem...

I can center the servo once, then it becomes inaccessible!
If I try to set the MIN/MAX values of the servo it is not responding,
dragging the slider of the servo panel does not have an effect either!

The board does not brown out and it does not drop out of the Wifi...

In my older projects everything works out fine!

#8

Have you tried a different servo? Perhaps something is wrong with that servo - or a wire is loose. It'll end up being something super simple that was overlooked Smile

#9

Looking at your EZ-Builder log activity, the JD and PWM Project are both disconnecting. Do you have any i2c controls that by no i2c devices?

When it "stops responding", is the red LED on the EZ-B steady on?

#10

The servo works fine and is responding, I tried different servos already!

No i2c devices are hooked up to the EZ-B!

I noticed after loading the JD default scene, I could not access the EZ-B and had to put in my Wifi network key once more to make it work!

When I open the JD default scene my servo moves one time and then stops responding, the light on the EZ-B turns to a steady red!