Bluetooth/computer Connection Problem

 
#1

It happens every once and a while. I am unable to get my board to connect with the computer. The battery (6V) is fully charged so I do not believe its a power thing. I have tried unplugging all of the ports to see if it connects but I get the same result. The connection button becomes frozen on the computer as well. I have also tried reinstalling EZ-Builder and the Bluetooth device with no success. Maybe the 6V battery doesn't have enough juice to connect and run all of the ports? I have tried a 7.2V battery as well but have the same result. Maybe 12V would be required?

The strange thing is if I open a new project or open firmware/debug windows the board connects fine. Another thing that happens is when I close out of my project completely and am looking at my desktop, the boards main light will become solid while the Bluetooth light continues to flash. I will reopen ezbuilder and the board will connect to the blank project without even selecting a com number. Then randomly or after a period of time I will go back and reopen my project and it will connect fine. I will have a week or so with it finds before it goes back to not being able to connect.

I am thinking it is something formatted wrong with my computer and the Bluetooth? I have a PC notebook with windows 7 and have to use a Bluetooth dongle because the computer did not come with Bluetooth capability. Could the dongle or computer be the problem? I'm not very good with electronics and I am trying my best to figure it out but I'm not having any success.

Has anyone run into something like this? I'm willing to go out and buy a new PC if that is what's required lol I really want to be able to work on my robot consistently. Any thoughts would be awesome

Aaron

#2

I get something like that too. It is actually the driver in the PC. I have to flick off and on my Wireless switch on the PC (it also controls the power to the bluetooth) to get it to begin working again.

It's not the EZ-B Hardware, it's the bluetooth driver in the PC. My laptop is a sony, and i have the same issue with my other 2 sony laptops. The Android tablet and two Asus laptops i have do not have the same problem.

It's kind of annoying when i'm demoing because i have to flick the wifi on and off and lose connectivity to the internets. Frown Stupid driver issues! Grin

#3

hi
i'm a novice here
can you help
every time i try to connact to my EZ-B
for witch i can only find one port
the bt cuts out. Ive tryed getting the firmware updated and keep getting this message

Attempting connection to COM7
Comm Err: The operation has timed out.
BbytesToExpect: 1

Received:
Disconnected
Connection Failed: System.Exception: Controller Not Responding
at EZ_B.EZB.Connect(String portName)
Disconnected

do i need a more upto date bluetooth dongle
or am i just being thick
ps love your work *confused*
cheers mate

#4

hello !

I had problems with connections also (MAC with W7 on Parallel desktop)

If you use "camera windows" in your project where you can't connect to EZB ,try to uncheck all the "tracking types" and try again.For me ,it work every time !I have not had any problems connecting with this trick.

#5

Have you added the ez-b to your computer over Bluetooth using the tutorial? With the native Microsoft Bluetooth stack, you will have two COM ports of successful.

#6

I have the same problem almost with my board currently. I just posted a forum to it, but to make stories short, only the red light blinks on my board, and not the blue light, in addition to the firmware saying the board has stopped working. Please help. Frown