#1

so i am not sure what I am missing as this is pretty simple... I am running this on my iphone... however, it will not loop (just runs once and stops)... i have other scripts running loops.. not sure why this does not work... maybe i still need coffee and I am overlooking something really easy..

:autor
ControlCommand("r2voice", Track_Random)
sendserial(d2,38400,50)
sleep(3000)
sendserial(d2,38400,128)
sleep(3000)
sendserial (d2,38400,100)
sleep(3000)
sendserial(d2,38400,128)
ControlCommand("r2voice", Track_Random)
sleep(3000)
Goto(autor)

#2

Does the script work in EZ-Builder on Windows? If there are errors the error reporting is more verbose on Windows than on the mobile app. A quick look, I don't see anything wrong with the script.

Alan

#3

There's a log view on mobile. What's it say?

#4

when I ran it I did not see a log on my iphone. It had the green start button and when I hit it the script would run (once) then the button would go from red (stop) back to green. I could hit it again and keep it going that way but the auto loop is not working for some reason. If you are wonder why I even want to do this.. its just an attempt to try and fabricate some kind of randomness as the personality gen does not work for iphone yet Smile

#5

Perhaps one of the send serial commands are wrong. That might stop the script.

#6

Did you look at the application log? I see no reference that you looked at the application log. It can be accessed on the main menu of the app. There is always something in the application log.