Smtp Client Questions

 
#1

Hey DJ, I have the SMTP plugin a go (really looking forward to using this), I seem to have it configured correctly to use my gmail account for SMTP, but when I run a script to send an email, I get this:

Error on line 1: Failure sending mail.

This what I'm using:

Code:


ControlCommand("SMTP Client", Send, "Weyoun7ster@gmail.com", "Bob Smith", "Test", "This is a test message")



Does anything look wrong to you?

#2

If you are using Google as the SMTP...

You need the port to be 587 and SSL checked.

#3

This is really awesome... I have yet to test it, though... My account is yahoo...

#4

I tried my Yahoo account as well and no go.

For gmail I'm use this config
https://support.google.com/a/answer/176600?hl=en

#5

Works fine - you'll have to revisit your configuration.

1) verify you are using the correct port and ssl is checked (587 for ssl). Always use ssl for google

2) verify you are using the right smtp (smtp.google.com)

3) Your authentication and FROM address usually must match for obvious reasons.

4) Find out more in the plugin: http://www.ez-robot.com/EZ-Builder/Plugins/view/128

Look at the example:
User-inserted image

#6

I get a new error now:

Error on line 1: The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.5.1 Authentication Required. learn more at

This is my config, without my real password
User-inserted image

#7

Use the correct password as the error explains.

Otherwise, look at your google gmail settings and see if you even have smtp access enabled?

#8

@DJ, lol...sorry for the confusion, I changed the password for purpose of taking the screen shot only. My real password is in the config.

Good thought on the account setting. I know there is a setting for POP, I never saw one for smtp, I'll double check.

#9

Worked fine for me on my google apps account. I think you do need to have either POP or IMAP enabled on your account in order to send through Googles SMTP servers. (settings | forwarding and pop/imap).

Alan

#10

Glad it works for you Alan. IMAP is enabled, google support page also said that it need to be enabled.

Port 587 per the google support page says it is for TLS and 465 is for SSL. 587 with gmail errors right off the bat for me. 465 just returns Failure sending Mail after a few seconds.

I can telnet connect to smtp.gmail.com 465 from my PC. Something is off but I can't pinpoint what or where it is. It's got to be related to my account settings, I don't think it's an issue with the plug in.

On a brighter note, I did get smpt.mail.yahoo.com to work with port 587 with my Yahoo email. The plugin does work (many Thanks DJ!) Gmail is just being a meany pants to me. Tongue