Award
Congratulations DJ Sures, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Sabertooth 2x12 V1.0 Responds Inconsistently With St Movement Panel

Assistance Requested

Help EEGbiofeedback with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

EEGbiofeedback claims to have checked these sources:
 
#1

Hello,

I tried connecting the EZ B v 4 to my 2x12 v1.0 Sabertooth and control it with the Sabertooth Movement control panel.

The robot is not responding consistently when I hit the up arrow as I demonstrate in the video below. It also doesn't respond consistently when I send it commands with EzScript either.

Here's my dip switch configuration:
User-inserted image



It may appear in my video that I'm having that common ST issue of no common ground but I'm powering the EZ B with the ST's 5 volt BEC so I do have a common ground. I tested it with a ground wire going to the 0v from the BEC also and the problem remained.

The issue continues whether or not I'm running the motors at full power in my script.

Code:


:top

#forward Slow at 20% motor 1
sendserial(D0,38400,84)
sleep(500)
#forward Slow at 20% motor 2
sendserial(D0,38400,212)
sleep(5000)
#below stops motor 1
sendserial(D0,38400,64)
sleep(500)
#below stops motor 2
sendserial(D0,38400,192)
Goto(top)




I don't see anyone else has had this issue.

I haven't upgraded my EZB firmware since I bought the unit? I couldn't find a firmware update method in the tutorials also.

Thanks,

Bill

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

I wonder if you are having an EZ-B brownout. I don't think the 5v BEC on the Sabertooth gives a lot of amps.

You may also want to try 9600 bps. I seem to recall some people had trouble at 38.4k.

There are no firmware updates for the EZ-B v4. There is an update for the WiFi chip. You need a programmer tool. See https://www.ez-robot.com/EZ-Builder/Open-IoT-Wifi that would not impact a Sabertooth though.

Alan

#3

Thanks Alan,

I just tried your 12v power to the EZB and with a common ground and that didn't fix the issue with the ST Movement Panel. That was a good suggestion though.

I'm not getting any error lights on the ST.

The code below with the 9600 baud rate also runs the motors inconsistently. I don't see any jumpers on the ST board or a dip switch configuration to change the ST to 9600 baud. I'm surprised the code below worked.

I don't see where to change the baud rate from the ST Movement Panel config screen.

Code:



:top

#forward Slow at 20% motor 1
sendserial(D0,9600,84)
sleep(50)
#forward Slow at 20% motor 2
sendserial(D0,9600,212)
sleep(5000)
#below stops motor 1
sendserial(D0,9600,64)
sleep(50)
#below stops motor 2
sendserial(D0,9600,192)
Goto(top)





Thanks much for the fast reply Alan!

Bil

#4

I've also experienced issues with 38.4 and sabertooth - i think their interrupts don't handle the baud rate well. 9600 is still fast enough for direction controls - more than necessary actually.

I'll add an option to change the baud rate of the sabertooth Movement Panel

In the meantime, most ppl use the Custom Movement Panel to create scripts that use the SendSerial()

#5

Here's how I have my 2 X 12 Sabertooth configured;
Running at 9600 baud rate
Dip switches
1 - on
2 - off
3 - on
4 - off
5 - on
6 - on

Code:



Forward
SendSerial(1.D0,9600,127) # motor 1 127 is full speed
SendSerial(1.D0,9600,255) # motor 2 255 is full speed

Reverse
SendSerial(1.D0,9600,15)
SendSerial(1.D0,9600,143)

Turn Right
SendSerial(1.D0,9600,235)
SendSerial(1.D0,9600,20)

Turn Left
SendSerial(1.D0,9600,107)
SendSerial(1.D0,9600,148)

Stop
SendSerial(1.D0,9600,0)


Give these settings a try and see if they work for you.

#6

Thanks Mates,

DJ's custom Movement Panel suggestion did the trick along with BjHouston's dip switch configuration for 9600 BAUD:
1 - on
2 - off
3 - on
4 - off
5 - on
6 - on

Cheers,

Bill

#7

The next EZ-Builder has a configurable baud rate for the sabertooth Movement Panel - which defaults now to 9600, which will resolve future issues.

#8

As a side note 38,400 baud works perfectly with the sabertooth 2 x 5 motor controller. However as mentioned, I use 9600baud with the 2 x 12 as I have also had issues with 38400 and the 2 x 12...