Distance Sensors Lack Of Timeout

 
#1

Hi,
I have an issue with some cheap HC-SR04 distance sensors, like the one described in this Arduino forum thread (http://forum.arduino.cc/index.php?topic=55119.0):

"...it doesn't appear to have an internal timeout for when it fails to detect an echo.
This sometimes results in the echo line staying high forever, even if you re-trigger a measurement.
The only way to get it to reset is by cycling the power."


One proposed solution is :"...When I detect the sensor is stuck, I simply switch echo pin to OUTPUT, put it into LOW state, and after a while re-set it to INPUT, then cycle again."

Do yo know if this solution is applicable to the EZB-4 and EZ-Builder? Or is there any other option you can think of ? (except buying new sensors, of course Grin)
Thanks

#2

Just a little "up".
No idea for my distance sensor problem ?

For now, I have to kick my robot's butt to reinitialize the echo line of the sensor... it is not cool Grin

#3

lol - other than using the ez-script Set() command to turn on/off a digital port, i don't see how else it can be done.

#4

@DJ thanks for your answer.
Sadly, playing with the Set() command did'nt help.
I am good to buy new distance sensors...

I read that SRF05 sensors were more reliable. These sensors will work with EZ-Builder, right ?

#5

Yes, the SRF05 work perfectly with the ezb4. I have several that I am using... I have them wired to use just one port for trigger and echo on the ezb4....

#6

Great!
Thanks @Richard.

#7

Hi,
@Richard, I have just received mySRF05 sensors. Can you explain how you wire them to use only one port for trigger and echo? Do you still can use the ultrasonic controls integrated in EZ-Builder ?

#8

https://www.ez-robot.com/uploads/3PingWireUp-635666787025204766.png

I think you misunderstood Richard you use one port for trigger only you still have to use individual ports per ping sensor on the echo I hope the picture above turns out you'll see what I'm talking about by the way that was furnished by hippie geek Louis

#9

See here... you want mode 2... SRF05 wiring modes Mode 2 uses only one port on your ezb for trigger and echo...

Solder these two contacts together (circled in red) to enable mode 2... So 3 wires... Ground, 5V , and trigger/echo...

User-inserted image

#10

Interesting Richard I learn something new every day thanks

Sorry for hijacking this thread