Award
Congratulations DJ Sures, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Ez-builder Dont Work By Make A Photo

Assistance Requested

Help lizpoir with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

lizpoir claims to have checked these sources:
 
#1

Hello,
i have follow Problem, the EZ-Builder Software dont works when i make a Photo. The EZ-Builder dont work by the follow Command:
ControlCommand("Kamera", CameraSnapshot)

here is the complete script:

ControlCommand("Leben", PauseOn)
ControlCommand("Speech Recognition", PauseOn)
ControlCommand("Kamera", CameraObjectTrackingDisable)
ControlCommand("Kamera", CameraMultiColorTrackingDisable)
ControlCommand("Lichtspiel", AutoPositionAction, "Sprechen")
SayEZBWait("ich zähle jetzt bis drei und dann mache ich ein Foto")
ControlCommand("Lichtspiel", AutoPositionAction, "Dauerlichtspiel")
Sleep( 500 )
ControlCommand("Lichtspiel", AutoPositionAction, "Sprechen")
SayEZBWait("eins")
ControlCommand("Lichtspiel", AutoPositionAction, "Dauerlichtspiel")
Sleep( 500 )
ControlCommand("Lichtspiel", AutoPositionAction, "Sprechen")
SayEZBWait("zwei")
ControlCommand("Lichtspiel", AutoPositionAction, "Dauerlichtspiel")
Sleep( 500 )
ControlCommand("Lichtspiel", AutoPositionAction, "Sprechen")
SayEZBWait("drei")
ControlCommand("Lichtspiel", AutoPositionAction, "Dauerlichtspiel")
Sleep( 500 )
ControlCommand("Kamera", CameraSnapshot)
Sleep( 500 )
ControlCommand("Leben", PauseOff)
ControlCommand("Speech Recognition", PauseOff)
ControlCommand("Kamera", CameraMultiColorTrackingEnable)
ControlCommand("Kamera", CameraObjectTrackingEnable)

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

Two questions.

1st one, I know it is probably stupid, but are you using the current version of EZ-Builder? There was a problem for many months with recording video and snapshots but it was fixed a month or two ago.

2nd, there have in the past been some issues with internationalization of EZ-Builder. Can you try changing your Windows default locale to US-English and see if that makes a difference?

I haven't tried with yesterday or today's releases, but I was successfully taking snapshots last week, so I know the feature has worked recently (I'll try when I get home or tomorrow morning just to confirm for you, unless someone else gets to it first).

Alan

#3

Is there an error that occurs for you with that script? Or does it simply not save the photo in the folder? Do you know where the folder is? The Config button on the camera control will provide a direct link to the media folder.

#4

Hello Alan, thanks for your Replay, i have the EZ-Builder - Version: Windows Release 2015.12.19.00
Newer Versions dont work correct with my Scripts.
A change of language according to US-Engl. I do not know that I had tried in the past year, and then the voice control went to the German version is no longer, I had to re-set up the whole operating system so that it worked again.

Hello DJ,
the script works fine if i set # before:ControlCommand("Kamera", CameraSnapshot)
I know where the photo is folder, there is no photo saved and the main problem is the complete EZ-Builder software is closes by the Command: ControlCommand("Kamera", CameraSnapshot)

Please clean up the error in the current EZ-Builder version, this I can not use because work no longer script. There are complied with no SleeP times, the RGB block does not work and SayEZB goes into utter confusion.

Thanks

#5

I would love to clean the error - but we cannot reproduce the error. Please tell me what error you receive with the command. Thanks!

#6

Fotoproblem.pdf

Please see the Attachement for my Photo-Problem.

The Problem with the Program Version newer Windows Release 2015.12.19.00 is really hard to explain. The 18 RGB LED block dont works, works incorrectly SayEZB all words are choppy, and the timings dont work (Sleep). In the Version Windows Release 2015.12.19.00 it works all fine without the Photo.

#7

I can't take snapshots any more either. I haven't played with this for awhile but it was working a couple of months ago. When I run this script it crashes the EZ Builder. I have tried it with the latest release as well as with the 12/31/2015 release.

Code:


ControlCommand("Auto Position", AutoPositionFrameJump, "Rest")
sleep(500)
ControlCommand("Camera", CameraSnapshot)
sleep(500)
ControlCommand("Auto Position", AutoPositionFrame, "Head Right",25,3,4)
sleep(4000)
ControlCommand("Camera", CameraSnapshot)
sleep(500)
ControlCommand("Auto Position", AutoPositionFrame, "Head Left", 25,3,4)
sleep(6000)
ControlCommand("Camera", CameraSnapshot)
sleep(500)
ControlCommand("Auto Position", AutoPositionFrame, "Rest", 25,3,4)


Video recording works fine.

#8

I am still unable to reproduce these results. Photos work fine for our testing - if you can produce an error, that would be the only way i can help Smile

#9

It doesn't show an error. It instantly crashes EZ Builder. I tried to run just this;

Code:


ControlCommand("Camera", CameraSnapshot)


Same result.

#10

By "crash", do you mean the program just disappears or is there a popup error message?

If there is a popup, which is what "should" happen, there will be a DETAILS button with an error message. You can press the details button, select the details, copy the details, and paste them here.

For copy and paste may require a right click of the mouse, or using the windows short-cut keys CTRL-C