Questions Installing 2015.12.19.00 Version

 
#1

I am a long time user of EZ-Robot. This is the first time I have had any problems installing a new version.

A bit of history about the computer I am using:
It is a Dell 'Latitude' Lap Top.
I used Windows 7 until last week when I was convinced that Windows 10 would be an improvement.
That was a big mistake for me. The WiFi connections became unreliable. I had to manually connect to my router many times.
I was given the opportunity to go back to Windows 7. I took it.

When I tried to load the latest version of EZ-Builder (2015.12.19.00) the download of the EZ-Builder Installer went as usual, the icon appeared on my Desktop.
I chose the Complete installation, hit "Install" and got this window:



User-inserted image
I hit OK in that window and got this:


User-inserted image
I hit OK again and got the same window so I hit Cancel and got this:


User-inserted image
I hit OK and got this:


User-inserted image

Help!

#2

Have you tried to manually remove EZ-Builder from Control Pannel/Uninstall Programs? Reboot Then install the latest version?

Of all the version releases I've only had an issue like this twice. Performing a manual remove and fresh install solved the issue for me each time.

#3

Justin,
I tried your suggestion. I could not uninstall from my User 'IRV' so I restarted and switched to User 'Administrator' and tried to uninstall EZ-Builder. I got the same window as the first one but the header was "Windows Installer".
When I canceled out of that I got a window that said, "The installation source for this product is not available. Verify that the source exists and that you can access it.

BTW Justin, thanks very much for your suggestion.

#4

Justin,
Do you think I should try to delete the 'EZ-Robot Inc folder from my Program Files(x86) folder?

#5

Using the search feature, this thread had a similar issue: http://www.ez-robot.com/Community/Forum/Thread?threadId=8749

#6

@DJ,
I jumped through all the hoops,
I went to: http://www.ez-robot.com/Community/Forum/Thread?threadId=8749
Did the steps in: ahttp://www.theeldergeek.com/manually_uninstall_programs.htm
Tried @thetechguru's:
msiexec /i "C:\Users\your windows user name\Downloads\ez-builder.msi"
None of these worked. In frustration I even did a system restore. Still no joy.
Google came to the rescue with a path to:
http://support.microsoft.com/kb/2438651
This microsoft support "How to troubleshoot Windows Installer errors" shows an option:
Run the troubleshooter to fix the problem automatically.
To fix this problem automatticaly run the "Fix problems that programs cannot be installed or uninstalled" troubleshooter to repair issues that block program installation or removal because of corrupted registry keys.

That went to a window that said,
"Fix problems that programs cannot be installed or uninstalled"
A Fixit sub window has a Run NOW button.
That loaded a program called: MicrosoftFixit.ProgramInstallUninstall.RNP.Run.exe

Running that program worked!
All is now well at the OldBotMaker's lab.
Merry Christmas and happy New Year to all EZ Robot owners, wanna be owners, operators, and staff.

#7

Awesome. Bookmarking this thread for future reference.

(fyi... Very surprised to hear you had issues with Windows 10. It has been flawless for mw, and fixed WiFi issues on two of my computers)..

Alan

#8

@thetechguru,
It was the WiFi issues that made me dump W10. Half the time when I turned the lap top on, the WiFi would not connect because the connection could not be found. Had to use the Network Troubleshooter to find and connect.
Others (DJS) have said that W10 does not handle WiFi well on some platforms.

#9

I guess I have just been lucky. Thanks for posting about the uninstall fixer. That is a great find.

#10

Almost forgot - this issue has been caused and resolved by Microsoft.