Sabertooth Troubles

 
#1

Hi guys,

I am currently trying to use a sabertooth 2x32 but am unable to get it to work and think it might be related the the DIP switches?

just for background:
-I have updated to the latest EZ-Builder
-the signal and ground of D0 are connected to s1 and ground of the sabertooth
-i have tried using both the sabertooth Movement Panel and custom Movement Panel using serial commands and have read how the interval 0-255 affects the motor coding.
-I have tried many combinations of DIP switches but I either get the motors spinning out of control (without command from the Movement Panel) or no movement at all

I am sure that it is something simple and figured someone has come across this in the past

Thank you for any input possible! Smile
Aaron

#2

I don't know too much about sabertooth but I have a 2 x 25 connected as EDIT ** sSimplified Serial Mode at 38400 baud edit *+ not seriel I see your data sheet does not say simple seriel but anyway d0 correct to s1 you only need to have the signal connected to S1 hope it helps Richard if you chime in you know these better than I think anybody else

#3

Have you looked at the QuickStart guide there is a link it looks like they do have a legacy for simplified seriel https://www.dimensionengineering.com/datasheets/Sabertooth2x32QuickStart.pdf


Hope this helps

#4

Hey robot56, have you viewed the manual page for the sabertooth Movement Panel? Did these dip switch settings not work? http://www.ez-robot.com/Tutorials/Help.aspx?id=173

#5

@merne I have that in front of me right now and cannot get either the rc or serial DIP switches to work

@Dj Sures Yes that was what I originally tried but one of the motors would just spin the moment I tried to use the Movement Panel or set up an init script send serial(D0,38400,0) . I figured there had to be something I missed since there was a supported control for the sabertooth lol

Aaron

#6

Robot 56 can you let us know what dip switches are set currently and are you using battery or power supply thanks
EDIT** Is your dip switch set for Legacy simplified seriel which I'm sure you tried since you have it in front of you

#7

I use the Custom Movement Panel for my 2 X 12 Sabertooth. The instructions for your Sabertooth should have the DIP switch settings. Here's my codes that may be of help to you.

Code:



# Both motors stopped, I also use this to initialize the board,
SendSerial(D0,9600,0)

# Forward
SendSerial(D0,9600,127) # motor 1 127 is full speed
SendSerial(D0,9600,255) # motor 2 255 is full speed

#Turn Right
SendSerial(D0,9600,255)
SendSerial(D0,9600,1)

#Turn Left
SendSerial(D0,9600,127)
SendSerial(D0,9600,128)

#Reverse
SendSerial(D0,9600,1)
SendSerial(D0,9600,128)

#8

Your DIP switch settings are: 1-OFF 2-OFF 3-OFF 4-OFF 5-ON 6-OFF

This is set up with the battery also stupid question but your wiring to the motors are they both the same

Also I am not familiar with your level of expertise so sorry if I'm giving you too many down the roads wrong answers

#9

One more thing that others haven't mentioned. Make sure the battery powering the motors shares a ground (but not power) to the ez-b.

Alan

#10

ok... it has been a long day... but I finally got it to work! I had the exact same code that @bhouston had written except for the braud rate of 9600. I changed the braud rate and re-configured the DIP switches to what I would have expected them to be and now it works perfectly!



thank you to everyone that helped me out it was really appreciated Smile
Aaron