So Weird : Ezb V4 Ultra Slow / Even On Ap Mode / And Some Really Weird Stuff : I

 
#11

Is your ezb mounted near any metal? My unit was mounted in the head of my all alimony robot. Key word was. I had experienced everything you mentioned including many many disconnects at the most in opportune times. I moved the controller to a plastic plexiglass mount that is mounted to the head now leaving the controller mostly exposed. I still have issues but have just accepted them at this point. Hope this helps.

#12

You are using a lot of ADC ports. I use all of mine and have no slow down. Like I said earlier; Only when I run the ADC monitor will my system slow down to a crawl. You don't need to run the ADC monitor window to use the ports. If you are using an ADC monitor window to view the reading of the ADC port try pausing all of them to see if our problem goes away. there is a little check box at the bottom of the window that says Pauds. Pausing the window does not pause the ADC port or them working.

#13

Sorry Dj i saw your very detailed answer only after I had posted my last message so it may have looked like I was not reading! Smile for now I'm busy with other things but I should be able to get back to it this afternoon and send you the report you asked for as well as the project's file. Thanks a lot for he great support! I'll finish reading all the posts as soon as I'm freed form current work (tons of philosophy papers to grade and comment! - my other hobby Smile )

Best,

#14

Damn ! I don't need to have all the arc monitors to run to use the command get(adc) ? Is that right? That would indeed solve the prob!

#15

Not really, no. For example, I only really use the actual ADC control monitors to get values when setting up scripts for sensors. After that, I delete the ADC controls.

#16

@Dj you asked earlier in this thread to communicate the router model(s) I'm unsing, regarding the DHCP bug of EZBV4.

The router which has DHCP server on my network used to be a Linksys E8350 (not really the kind of "cheap router" or "old router" that you and Alan referred to in your posts.

Now I have a brand new Netgear Nighthawk X6 R8000 and STILL THE SAME problem.

Lately, after creating a robotics class, I wanted to order 10 units of EZBV4 but I was asked not to by my School's IT director due to the fact that this issue ALSO HAPPENS ON OUR NETWORKS at school.

EZB is a great product but on that one your manufacturer messed up pretty well. It is not acceptable that such a device takes over our routers the way it does.

Here are the facts :

IF and ONLY IF my DHCP server is on the same subnet and same IP address base (192.168.1.x) THEN no problem. BUT AS SOON AS it is logged on a wifi network that uses a different subnet and/or simply a different address (like 192.168.5.x at work or 192.168.10.x at home) EZB ASSUMES that there's no DHCP server on the network.

Please, try using it on a different subnet, you'll see, the bug is systematic. This is annoying, not counting my wife yelling when she can't get Internet access on her macbook (@Alan knows that I know how to resolve that issue, it's simpler than this dhcp server issue... Smile Smile )

Sorry for the lashing out here... but I've been trying everything for days until I found out today that this is purely due to subnet or address format difference and therefore that there's nothing I can do. I can change my infrastructure at home, but not at work... it's simply and purelly going to be a loss for you. And we are in the center of Manhattan, and a famous school and a lot of people are looking at what we do. You want me to continue using your hardware... really. Sorry to use this stick and carrot here, but this is truly unbelievable that there's still no fix for this.

Thank you for your understanding.

#17

If you wish to upgrade the firmware, visit this url: http://www.ez-robot.com/EZ-Builder/Open-IoT-Wifi

#18

Thank you. I was waiting all this time for this promised tutorial (previously mentioned in this discussion). Didn't know it was out already. Since it uses a hex file it should be doable from arduino. If I figure it out I can post about it. Thanks again and again sorry for the frustration... currently my smartthings is crashed again because of bad dns. which means that it impacts my entire house... lights, heaters, all sorts of smart outlets and power meters.

#19

There is no dns server on the ezb.

The dhcp on the current v4 has an issue with some hardware. The upgraded firmware from the tutorial will fix that: http://www.ez-robot.com/EZ-Builder/Open-IoT-Wifi

#20

And of course new ones are shipping with the new firmware and don't have the issue so ordering new ones for the school is not an issue.

Alan