Trouble Connecting 2 Ezb's

 
#1

I'm trying to connect two v4's in one project, but no dice. I know someone had this trouble before, but can't find the thread.

They are both set to client mode, and the both connect individually. I've...

Reset the router,
Turned off firewalls,
Restarted EZ Builder,
Restarted my PC,
Disabled antivirus
and batteries are fully charged,

but none of that makes any difference. I have one board connecting to #0 and the other on #2. When I run a board search, only one will show up which I think is the last one that successfully connected. When I kill the power to one of the v4's, the other connects fine. As some of you probably know, I'm no networking expert by any stretch of the imagination, but I'm sure I've done right.

Any help would really be appreciated with solving this.

#2

You may have better luck assigning the IP addresses by MAC address in your router, and give the EZ-B's the lowest available values (ie, EZ-B 1 gets 192.168.1.2 and EZ-B 2 gets 192.168.1.3). If you always start EZ-B 1 first, then even if you are getting the DHCP bug where EZ-B 1 is handing out IP addresses, the address EZ-B 2 will get will be the same. (also, make sure the computer is started before the EZ-Bs so it is getting its address from the router and not from the first EZ-B to start).

To prevent other devices from getting those low addresses, either assign IPs to every MAC address on your network, or set the general DHCP assignment to start at a higher number (like 192.168.1.100)

If none of this makes sense, post the make and model of your router and I'll see if I can find an online manual and give you step by step directions. Just be aware that I am going to be offline from this afternoon through all of tomorrow, so it may be a couple of days before I get back to you.

Alan

#3

Thanks for getting back to me Alan. Yes this is way over my head. My router is a Virgin Superhub 2. I didn't think it would be this difficult to connect two v4's to one project.

How do I even find the EZ-B's MAC address?

#4

I find I am able to do it if I assign static IP addresses to my ezbs.... I have no problem keeping 2 ezbs connected to ez builder this way.... I use search to find the first ezb then connect on board 0... Then I manually type in the static IP of the second one (don't use search to find the second one) in the space for board #1 then connect that one as well...

#5

Well I found the MAC addresses for both boards, but I don't know how to assign static IP addresses for the boards. I've been through the routers settingsamd did a quick web search but can't see an option for it.

#6

Couldn't find a manual, but found this video. https://www.youtube.com/watch?v=Dr46nhKhHI4

If shouldn't be this difficult, but there is a bug in the V4 that keeps DHCP server on when the device switches to clent mode. If your router's DHCP server is faster than the EZ-B's, you will never see it, but if it happens, it can cause various kinds of odd behaviour. DJ is waiting for an answer from teh Wifi chip provider on how to fix it. http://www.ez-robot.com/Community/Forum/Thread?threadId=7229

Alan

#7

Thanks Alan.

I just spent the past hour changing things in my routers settings. I cleared the DHCP reservation list then reapplied the two boards again. They have 192.168.0.3 and 192.168.0.18 but the same thing happens, so it sounds like this bug is causing the issue. I take it that there is no way around this? I want at least one of the boards connected in client mode for web access and I'm guessing that putting the second board in AP would mean that I would lose that web access?

#8

Sorry Richard. Wasn't ignoring you, just realised that I forgot to mention that I tried it the way you mentioned, but it didn't work for me I'm afraid. Like you say, you manage to connect multiple boards and I'm sure others have too. Just can't see why I'm (and others) are having trouble. Are all the boards you're using in client mode?

User-inserted image

#9

Yes, all my ezbs are in client mode... I give them all static IPs so when connecting I don't need to search for them as I already know what their IP address is... It's just a matter of tying their ip address into the connection control and pressing connect.... I type in the first one to board 0... Press connect.... connected. Then in board 1 I type in the second one, press connect and the second one connects.... I haven't tried 3 yet, but I am assuming it would work...

#10

Here are two of my ezbs connected...
User-inserted image