Connection Question With More Then 1 Ezb4 Controller

 
#1

Hello,


i have 3 EZB4 Controller.

I try to connect all Controller as Clients in my network.

If i connect 1x EZB4 "192.168.178.21" everything works.


If i connect 2x EZB4 "192.168.178.21 + 22" i get only the web interface from the first one "21". I also find only one the "21" in the EZB Software - not more!

The same with 3x EZB4


To my Router:

I check this situation with two diffrent routers Fritzbox 7330 and Fritzbox 6840.

I see ALL 3 x EZB4 Controllers correct conneted in the WLAN! But only the "21" Controller Web Interface works!

I set the channel settings from the first EZB to 1, from the second to 2 and from the third to 3.

I donĀ“t know.

I only can connect 1x EZB as a client to my network! Not more!

So what is the problem?

Thanx a lot!


Boris

#2
#3

Hi DJ;

i know all what is writen in this tutorials!


Boris

PS:

If i connect single to each controller, they work fine, but together!

#4

When you type in the IP address of your browser for 192.168.178.22, you get the webpage for 192.168.178.21?

#5

Check and see if your firewall is on. I could not connect to more than one EZB, in client mode, until I turned it off.

#6

There is a bug where the DHCP server still runs when the EZ-B is in client mode and it responds faster than some routers (I see the issue with TP-Link routers but not with my new Verizon router that responds faster to DHCP requests.

The first one on the network will hand out the lowest available octet addresses, so once the second one starts, it will be 192.168.178.2 if that isn't already assigned on your network.

The search function in EZ-Builder should find them whatever addresses they wind up with.

This thread provides more detail and more information on workarounds:

http://www.ez-robot.com/Community/Forum/Thread?threadId=7229

Alan

#7

Hello Bhouston,

no the firewall make no problem,


but after your tip, i hack the ezb4 controller manual with the MAC Adress to the Router/Wlan Config and now all are working!


Thanx you tipp help me!



Boris

#8

Boris, I don't understand what you did to make this work. Are you saying you assigned each ezb a static mac number in your router's DHCP section?

It's gerat that they are working now. Smile

#9

Hi Dave,

yes, i connect each ezb4 with this MAC Adress to my Router.

I heard this from other FritzBox User this can help sometimes.

One EZB the FritzBox like, but 2 definitiv not. Only with this MAC Adress Connection.

But it ok! I had now 5 times Notebook and Router off and after Restart again, every EZB connected correct to my Network.

So the "Bad Boy" in this Story is the FritzBox!



Boris

#10

Sorry, I don't get this. I thought the EZ-B's had their own hard coded MAC addresses that can't be changed, so how can someone be using multiple boards with just the one, same MAC address? I don't know much about this subject, and I don't understand how this issue was resolved.