Well, It Finally Happened To Me

 
#1

I have never blown a board due to being careless, until yesterday...

I am was using an Arduino Mega for gathering information from a Neato XV-11 LIDAR sensor. I had disconnected the power cables and unplugged serial port wiring to mount the board on my control box. After getting the Arduino mounted and plugging in the cables again, I attached the 12v battery. Things went down hill from there.

Sensor readings were not coming back from the LIDAR and I messed around for about 10 minutes trying to figure out why. When I inspected the wiring, I realized that I had plugged the ground wire one spot too far to the right (VIN). The board was already grounded through the 12V plug. The ground wire that was plugged into VIN on accident was plugged into a Beaglebone Black into a ground pin. The BBB wouldn't boot up. The LIDAR was plugged into power on the Arduino along with the serial connections and the other serial connections were going to the BBB.

The BBB looks to have survived the mistake. The Arduino definitely didn't. I don't know about the LIDAR. The EZ-B for this project is still in the box, so it is okay Smile Thanks to RobotDoc I have a logic analyzer so I will be able to check the LIDAR to see if it is sending back packets or not shortly.

Long story short... Always double check your wiring, especially on a board that you are not familiar with. It gets easy to get in a hurry and make a stupid mistake costing you money for replacement parts, but more importantly time waiting for the parts to arrive.

On another note, I have a Flashforge Pro 3D printer that I am using for this project. It is a Makerbot 2X knock off. There is one issue that had me stumped for a couple of days. The printer would just start jerking for no reason. I could jog the controls in either X OR Y without any of this jerking happening. Finally, I brought the extruders to the front left corner of the printer and told it to home (which moves the extruders to the back right side of the printer). The jerky activity started about 2/3 of the way back from the front left. This told me that it was nothing with my slicing settings. I then did some looking online and discovered that the X axis stepper motor cable on these printers can develop micro fractures due to repeated bending. These cables are not designed to be bent over and over again. I manufactured a cable and tested this out. It worked without any issues for a while, and then the problem came back. I am sure that the wire I used could have the same issues and probably more so due to me doing this quickly to identify the problem. I pieced some jumper wires together to make this cable. Now I wait for the 4 replacement cables that I ordered.

So, I am waiting until I can continue printing, and I am waiting to be able to continue working on the SLAM parts of Rafiki. Good time for me to check in and make sure that the other development is progressing.

We have decided that the parts of IBM's Watson solution that we were looking at using are not quite up to par with some things we can do ourselves. We have backed off on using Watson for now and are working with Wolfram for the knowledge and information pieces of this project. Unfortunately with a project like Rafiki, you try some things for a while and at some point you have to decide that its not worth it going down the path you have been going down. Time spent but knowledge gained. Knowledge doesn't have a price tag so no problem in my book. We are falling a bit behind but the robot will have more capabilities than I first imagined in the long run.

Have a great day everyone.

#2

Oh, one more thing. We are using LiFePo4 batteries with this project. So far I am very impressed with how long these guys run. The batteries that we are using are self balancing 12v 20ah batteries. They last a very long time. I have been working on the logic boards (all of them on at one time), along with using the 2 drive motors a lot to get the exact settings for moving robots specific distances, or turning specific degrees and have only had to charge this battery 2 times in the past month. The max draw from this battery is 30 amps. It weighs only 7 lbs. Incredible batteries but cost around $125 per battery. Our goal is to have up to 3 of these in a robot providing an incredibly long run time. The customer will be able to specify how long they want their battery to last between charges, which will determine how many of these batteries will be included. My original estimates of 8 hours on a charge per battery so far appear to be way low. Toymaker told be they were, but, you know how it goes. I had to see it to believe it.

#3

Ouch. Another Arduino board goes to the great microchip in the sky. It's easily done though. I had something similar about a week ago with a motor controller. All wired correctly, except for on teeny tiny strand of wire which was so difficault to see, caused a short, so when power was applied I heard the inevitable "pop" and saw a spark. Ended up burning out one of the channels. Luckily enough I had a couple of spare controllers and I'm sure I'll find a use for a one channel motor controller one day.

In regards to the LiFe batteries, do you know if they can they be charged while still powering a device like NiMh cells can, but LiPo's cannot?

#4

I don't know about that. I do know that the ones that I bought have a shutoff at a certain voltage to protect the batteries and a over charge protection. These are used to replace motorcycle, ATV's, car batteries and with this protection on them are safe to do so. I would think that you would want to disconnect the battery about once a month to allow the balance modules to balance the cells. Because these are used for these other applications (along with solar battery banks) I believe that there is no issue doing this. They sell them without the balance modules, but I would go with the ones that have them personally. The ones that I have are rated for between 1000 and 2000 charge cycles. At this rate, I will be done before the battery is...

#5

Lol, that last comment made me laugh. Thanks for the info though. I'm in the market for some new batteries for my E4 build, and was going to go with a high ah 12v SLA, but I am tempted to try these LiFe batteries for myself.

#6

I went with these because when you look at the number of cycles and how long these last, they are cheaper than SLA's. They also give you more max amps than the SLA's will. Not on the scale of the straight LIPO batteries, but still much better and far lighter than SLA's.

#7

Yup. We've all been there. I can also say Electronics and beer(s) don't go together well...

#8

Mine was lack of sleep. I'll be rested by the time the replacement parts arrive I suppose Smile

#9

the late nights and working till the early hours......i know it well.

#10

Every component that I havw burned out was from working too late at night when I should have been asleep. So hard to put it down and walk away when you are "this close" to solving an issue.

Alan