Award
Congratulations CochranRobotics, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

What's Wrong Whit This?

Assistance Requested

Help Aerius with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

Aerius claims to have checked these sources:
 
#1

Error on line xx: Missing ) in Expression when I run this:

Exec("c:\Program File(x86)\RoboRealm\RoboRealm.EXE")

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

Try this

Code:


$roborealmpath = "c:\Program File(x86)\RoboRealm\RoboRealm.EXE"
EXEC($roborealmpath)



The issue is that the EXEC command doesn't like the (x86) piece of your path.

I would also recommend launching the .robo file instead of the exe. The exe is linked to the .robo file (or the other way around) and it will open the .robo file in roborealm. This will allow you to launch different .robo files depending on what you are doing within RoboRealm.

#3

Put another ) at the end and see if that helps.

Edit, never mind. *tired*

#4

@David
same error when I run:
$roborealmpath = "c:\Program File(x86)\RoboRealm\RoboRealm.EXE"

@Dave
Try to add () at different places with no success

#5

Try this,

Launch Roborealm and build your project in RoboRealm. Save the project to your my documents folder or wherever you want to store these, and then use that path to launch it. This is how I do it and how I setup @fxrtst's to work last night.

#6

@David
I did move my file elsewhere and now it works
Tanks

#7

You bet. Let me know if you have any questions about roborealm. I have become fairly good with it.