Credit Card Information

 
#1

Whenever I get to the credit card information and try to fill it in, the page immediatley takes me to a new page and I can't fill anything in. *stress*

#2

@annagill326.

There does seem to be a slight issue with using the card payment option as you have witnessed. I just tried the credit card procedure myself and it redirected me to the "Find your nearest retailer" page.

The only thing I can suggest at this point is if yourself or someone you know has a PayPal account then use that as that seems to be working fine, or to use one of your nearest retailers if you can. Otherwise you could wait for the guys at EZ Robot to fix the problem which shouldn't take them very long. I have contacted them already so it should be resolved pretty soon.

#3

I just tried it and did not experience any issues. What web browser are you using? Any additional information you can provide me with to rectify the issue would be appreciated as well. Thanks! Smile

#4

@DJ.

I tried it to help the poster on an iPhone 6 plus with Saffari. As soon as I press the text input field to enter either the card number, expiry date, or when I press the drop down menus, it redirects to the "find a supplier" page. Just tried it again and it still does it.

EDIT: I just tried it on my Acer laptop running Mozilla Firefox and it does the same as above. The item I'm trying it on is JD. Hope that helps. Smile

#5

Interesting - are you pressing enter when inside the box?

#6

Got it! Thanks for bringing it to my attention Grin It's resolved!

#7

@DJ.

No worries. Just to confirm, I was pressing Enter in the input field. Glad you got it sorted. Smile

@Annagill326.

See, told you it would get sorted quickly. Happy ordering. Grin