Award
Congratulations thetechguru, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Ez-b Client Mode And Router Conflicts

Assistance Requested

Help OldBotBuilder with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

OldBotBuilder claims to have checked these sources:
 
#1

My problem is when I connect EZ-B in client mode my wife's WiFi connection goes down.

@thetechguru stated in thread: http://www.ez-robot.com/Community/Forum/Thread?threadId=7722 post #5 that:

Quote:

Although connecting in Client Mode, where the EZ-B connects to your router is probably best, the issue you are probably having is an IP subnet conflict in the wired and wireless networks.

The EZ-B, in AP mode will have an IP address of 192.168.1.1, and will give out addresses to PCs in the range of 192.168.1.2-192.168.1.255

It is likely that your router uses the same range. 192.168.0.1 and 192.168.1.1 are the most common home router IP addresses with 192.168.1.1 being used by 95% of the vendors. You can't have two network interfaces on the same subnet. You can usually easily change this in the DHCP settings of your router to use another range. Anything starting 192.168.x.x is good for home routing (there are two other ranges, 10.x.x.x and 172.16.x.x through 172.31.x.x you could use as well).



I have an ATT supplied 2 Wire 3801HGV router.
I logged on to the routers URL and got the Gateway information/configuration pages.

This note from the 2wire/3801hgv/manual-1320.pdf:

[quote]By default, the gateway uses the 192.168.1.0/255.255.0.0 IP address range. You can select from two additional IP address ranges, or configure the network settings manually. When you select either of them, the LAN clients are assigned IP addresses within the specified range.
Note You should manually configure these settings ONLY if you thoroughly understand IP internetworking. An incorrect configuration can cause unpredictable results.[//quote]
seems to indicate that changing the ip address is not a good thing to do.

What ip address(s) should I use and how should I change it/them so my system does not crash or nodes disconnect?

Any advice will be most welcome.

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

I think your issue is probably different than IP subnet issue since it is a wireless problem. I was really talking their about connecting to an EZ-B wireless AP mode and a wired network at the same time.

That being said, I am convinced there are one or more problems with the EZ-B in client mode and it not turning off its dhcp server (and I have provided network traces in a bug report to prove it) which causes issues with multiple ez-b's on the same network. Depending on your network settings and your wife's computer settings there may be a conflict with just one EZ-B. I don't have availability today, but tomorrow I will look up the manual for your router and make some recommendations on how to prevent possible interference.

Alan

#3

Alan,

Thanks for your reply. Looking forward to your recommemdations.

#4

So, the manual I found is a little weak on details on how to do what I want to suggest, but it looks like the router is capable of doing it. I think it would be best to assign specific IP addresses to the devices. Your router calls this "address allocation" nd the instructions (such as they are) are on page 70 of the manual I located here: http://setuprouter.com/router/2wire/3801hgv/manual-1320.pdf however, it isn't clear from the manual how you select each device to set its IP.

If we can figure this out, I would suggest giving your EZ-B the address of 192.168.1.2 and giving your wife's computer an IP address 192.168.1.100 or higher.

Interestingly, on page 69 of that manual it indicates you can actually have multiple subnets defined. That would allow the E-b to be on a totally separate subnet from the other devices and ensure no possible conflicts. But again, the instructions are a little weak, and it is not clear if the router passes traffic between the subnets, which would be needed if your computer is on one and your EZ-B on the other. I actually do this at home, but I use multiple routers to do it, not something I recommend for most users, and I do it so that if I travel with my robots I can take the router with their network with me and not need to worry about changing modes or telling the EZ-B to connect to a different network.

It might be best if we arrange a Teamviewer session where I can log onto your router from a shared session on your PC and poke around a bit directly. I am available today from 11am to 7pm ET. I do need to go out for an hour or so, but if we schedule something I can work around it. Drop me an email at alan@thetechguru.net and we'll make arrangements.

Alan

#5

This is a work in progress.
@thetechguru is working with me to resolve this symptomatic problem that seems to be inherent with the 'Client Mode' of EZ-B WiFi connection.

#6

(If we can figure this out, I would suggest giving your EZ-B the address of 192.168.1.2 and giving your wife's computer an IP address 192.168.1.100 or higher. )

Thanks I will try it http://192.168.1.2

#7

Stha2232 unless you have an older EZ-B, you should not be experiencing this issue it was fixed some time ago. If you are having it, you can flash the current firmware with an inexpensive tool see http://www.ez-robot.com/EZ-Builder/Open-IoT-Wifi

Alan

#8

Alan,
Is there a way to tell if your EZBv4 has the old firmware?

#9

When you connect to its Web page, it won't have a firmware version number on the lower left.

Alan