Why Isn't My Servo Working

 
#1

As the title says. It's an EZ robot micro lever servo. When I try to move it with a script or "H" or "V" servo control... Nothing.

It's not released

Ezb is connected

7.4 LiPo battery is fully charged

Ezb has been power cycled

Doesn't work on different digital ports

It's connected correctly (and always has been)

It worked up until yesterday

It's not under any strain in any way

It's been calibrated correctly (it used to work ok as mentioned above)

Other servos work on the same ports

Wires have freedom of movement

Tried a new project with just a vertical servo control

Moves freely when I turn it by hand (connected or not).

Any ideas?

#2

open the servo see for burn marks

#3

It's a bit difficault to get to at the moment unless I do a major disassembly of the robot. I don't want to do that just yet until all other avenues for remedies are exhausted.

Thanks anyway Patrick.

#4

Looks like you've done as thorough a diagnostic as possible. It appears to be an electrical failure within the servo. A continuity test of the 3 leads might locate something or point to an internal issue.

#5

@Steve G,

Did you try the old stand by for any Windows computer? Reset everything.
Close EZEz-Builder, reset the computer, re-install EZ-Builder, start your Project, re-establish the WiFi connection, finish that beer, cross your fingers, then try out the servo control.

#6

ah ok

#7

Your servo is broken. What's connected to it?

#8

Great *eyeroll*. It's connected as seen in the photo...

User-inserted image

The head weighs about the same as a JD head so weight should not have been an issue.

#9

It looks much larger, and has a metal speaker with magnet, and more plastic... visually it appears to weight more. I would assume your servo is not working because it is damaged. Easily replaceable Grin Although I do recommend a larger servo. Those little guys are only good for a small amount of weight.

#10

@DJ.

I take it you havn't seen my showcase then. The speakers (with magnets), battery, some of the internal plastic, and circuitry had all been removed, and speakers placed in to the robot body (as seen in my "making of" video in the project showcase). It's just an empty lightweight plastic shell now with the exception of two LED's, two sound sensors and camera added. I only had the thing working for two weeks before this happened. It may look bigger, but I assure you it's is about the same weight as a JD head.
User-inserted image

User-inserted image