Vertical And Horizontal Servo Control Movement Bug

 
#1

After downloading the two recent updates I've come across something which I think may be a bug. When setting up or using a servo in either the vertical or horizontal servo config screen or the interface itself, when I left click or touch the screen to set or move the servo, a drop down window keeps appearing with all the servo values and can no longer slide the mouse pointer of my finger on the screen to move the servo in real time. Is this a bug or new feature (which I hope it's not)?

Thanks.

#2

1) This is a feature and is only enabled when you RIGHT Click. This will never happen with LEFT Click.

2) Microsoft Windows was designed to simulate a RIGHT Click when you hold your finger for a length of time on the screen in the same position. This is a feature of Microsoft Windows and not EZ-Builder. I'm not actually sure where you can adjust the "hold for right click" option. Perhaps the Mouse settings in control panel?

#3

This is strange as it was working last week on the same machine, on the same project via touchscreen and track pad, either double tapping the pad or left clicking. I noticed the right click feature in the auto position a couple of days ago which is very handy and worked well. I posted up a short video for you to see what's it's doing...

#4

Maybe reboot your computer? Touch events are built into the Windows Operating system. There is an event for Left Click and an event for Right Click. If Microsoft Windows is sending the incorrect event, that may because the computer needs a reboot? Sometimes Windows gets confused.

In your video it looks as if the computer thinks everything you are doing is a right click. Reboot your computer and hope Windows smartens up

FYI, when Windows starts doing funny things... reboot. It's kind of an ongoing joke with Microsoft Windows that rebooting fixes it Smile

#5

Hey DJ.

Well I tried the reboot as you suggested (truth be told I did it earlier also, but didn't heart to try again), system restarted and left/right buttons and trackpad double tap work as they should. But on the servo control... No dice.

I put up another video (after reboot) showing that the buttons and trackpad are working as they should when opening up applications, but not with the servo control...



EDIT:

Just to note, this doesn't happen when I use auto position to set up frames. That works fine.

#6

Crazy - works fine on my end. Are there touch settings or keyboard programs running? Something that's installed to alter or assist keyboard languages?

#7

No, nothing else like that is running or installed. Like I say, it worked fine last week and weekend with no changes to the laptop or OS made since. It is a strange one as I mentioned in my edit, the auto position works excellent (as well as everything else, system apps and programs and EZ-Builder controls), and the buttons or touchscreen work as they should. I'm not too fussed if I'm honest as I only use these controls for testing or getting servo position values for scripts. But I can use the auto position for that. I just thought you might like to know I case it was a bug, but then it works fine your end and there's been no other reports so far. Weird.

Anyway thanks for the assist DJ. Much appreciated. Smile

#8

Sorry to bring this up again DJ, but I'm now having further issues with this servo drop down menu when using left click/double tap/ screen drag. Now it's not just the vertical and horizontal servo controls doing this, but it is now doing it when creating frames in real time using auto position.

As of last Saturday this was working absolutely fine and I even made and posted a video of some dance moves using auto position. So I went to create some more auto position frames and I'm getting the same drop down servo value menu when I'm left clicking, double tapping the track pad, and dragging my finger on the screen. I tried creating a frame with the drop down, and VERY nearly burnt out a servo as the wrong value was selected. I really need some help with this before I do actually damage something, or before I give up completely on using auto position all together as it is too difficult to use now. And what I said about not being too bothered about using servo controls for real time testing, as I can use auto position, is now no longer the case.*stress*

One thing of interest I have noticed, is when I disconnect the EZ-B and close my EZ Builder project, when I reopen it (without connecting the EZ-B), the vertical and horizontal servo controls and servo widgets when making frames in auto position work correctly with left click/double tap/screen drag. But once I connect the EZ-B, I'm back to square one again. *confused*

My laptop is no different than what it was last week, no added programs, no updates, nothing conflicting running in the background, same project, same EZ-B, and curious to why things work correctly when the EZ-B is not connected (although I do have to close and reopen the project), so I'm REALLY confused to why this is happening, and really taking the fun out of things.

Please help.

Steve.

#9

Okay, so I have a further update. It's deffo not an EZ Builder bug as you said, and it's not a problem with my Acer laptop or windows 8.1 as I suspected. I believe it it the project itself causing the headache.

I powered up my old HP laptop with Windows 7, and downloaded the same project from the cloud on an older EZ Builder release, version 2015.01.11.00. Exactly the same problem occurred. So I opened up a new project, scanned and connected to the EZ-B, and added a vertical servo control. IT WORKED. So I did the same on the Acer and it worked as it should too. So there's obviously something in my project that's causing the issue. If yourself or one of the guys at the office, or anyone on the forum could very kindly take a look to see what is causing this, I truly would be very grateful, as I have put a lot of work in to this and would hate to start over, not knowing the cause. the project is in the cloud under Steve G, Victor project 1, and is also linked to below.

Many thanks in advance Smile

VictorProject1.EZB

#10

For some reason youtube is giving me errors with the video I am uploading from my phone - I loaded and used your project with touch and mouse without problems.

As I stated, there is absolutely zero (none, zippo, nada) code in any windows program to determine mouse clicks. The operating system provides the event on Activities, such as mouse clicks. So every time a RIGHT mouse click is pressed, the function event for RIGHT mouse clicks is executed, same applies to LEFT clicks, and every thing else.

In EZ-Builder, MS Word, Photoshop, Chrome, anything - it's all the same. They respond to the events triggered by Windows.

I understand that's not what you want to hear - because you want a solution Smile However, if it was happening to me.. I would consider a few things.

1) Do I have a virus, Trojan or key logger?

2) Is my mouse/touch driver up to date?

3) Are there any windows updates that need to be done?

4) Is my screen cleaned with windex and a soft cloth? Touch screens use capacitive touch and dirt will simulate right mouse clicks. Turn off your computer and clean the screen with windex

5) Is there a program installed that is for remote desktop or vnc, etc... maybe it is interfering with the keyboard hooks