Award
Congratulations DJ Sures, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Auto Position Question

Assistance Requested

Help Toymaker with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

Toymaker claims to have checked these sources:
 
#1

Can anyone help me please, I maybe being dumb but I cannot find a way to permanently change the delay in Auto Position it always reverts back to 25 which is infuriating as my smart (Bosch) servos do not like this delay and I have to reset it back to 0 every time I use it (click on the cog icon).

DJ, is there any way I can set the delay to 0 (instead of 25) so that it always defaults to the zero value?

Any help is appreciated.

Tony

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

@Tony.

If I understand what your asking (and correct me if I'm wrong anyone), then I don't think there is a way to change it as I think that 25 is a permanantly set default position and can only be changed when editing frames and actions. I've been playing with Auto position all of yesterday and this morning for the first time with Victor (video will be posted later) and havnt come across a way to do this. The only way I know to do something similar is to set the delay to 0 when editing frames or adding frames to actions.

#3

Steve G, that is what I suspected but it is a real nuisance when playing around with Auto Position (which is really neat). I am hoping that DJ could do some magic for me and allow the default delay to be set to zero!

Tony

#4

Each frame within the "action" has its own delay. The delay value that you are changing is the delay value used when adding a frame to an action.

To change delay values of frames within an action, double click on the frame and a window will appear which allows you to edit the values for that frame.

You do not want a value of 0. Because that means there is 0 delay between steps between positions. Maybe you want a delay value much higher, say 1000 and a step value of 180.

#5

DJ, thanks for responding, but any delays greater than 20 give the ALTAIR arms great problems with shuddering to complete non operation depending on the delay value (shuddering starts at delay = 21). I think it is because I am using my custom (PIC based) Smart servos, I guess its not a problem with regular servos, so this problem may just be with my setup. A zero setting gives very smooth arms operation on the EZ:1. I am now getting used to always taking "delay" back to zero every time I click on the Auto Position gear, so its not such a great problem now..

I only just started using it, but I think Auto Position is very powerful and a really neat function.

Tony