Award
Congratulations DJ Sures, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Assistance Requested

Help jop with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

jop claims to have checked these sources:
 
#1

Hi,

I just got a Roli robot for some SLAM experiments, but the camera does not work. I was trying the tutorial with the red ball that should be tracked, but the camera showed up as disabled in the on screen log.

The camera is plugged into the EZ-B board in the only correct manner there is possible.

Please, do you know what could be wrong ?

best

Jan Pedersen

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

Can you see a solid blue led light through the white casing? If not you can try Very carefully removing the camera from the casing... Unplugging it and plugging it back in again... Could just be a lose connection....

#3

Hi Richard,

Thanks a lot, I can see the solid blue light through the EZ-B casing, but it is blinking. Is this ok ?

/Jan

#4

Just another thing: everything else works. All the servos work and the robot can dance and wave

#5

When the camera is working correctly the blue led will be solid... it should only blink momentarily when you first power it on... Are you using the same IP address for the camera as for your EZB?

#6

Camera IP is "EZB://192.168.1.1" and EZB IP is "192.168.1.1:23", so same IP but not port designation for the camera. Could this be the fault?

The strings above are copy and paste from the GUI of the desktop app.

The blue light is still blinking

/Jan

#7

Your IP's are good... Stupid question, but in the camera control did you click start to start the camera?

#8

After restarting the EZ builder and reconnecting WiFi the blue light is constant (non-blinking).

I did press start to start the camera, but I think the client sw discovers that the camera is disconnected and returns to a stop mode so that the start button is visible again.

The camera is still shown as disconnected. I have tried to mingle the cables with no success

#9

I got a log:

-------------
20-02-2015 17:48 - Camera Initialized: EZB://192.168.1.1 @ 320x240
20-02-2015 17:48 - Object Recognition loaded.
20-02-2015 17:48 - Camera Disabled
20-02-2015 17:48 - Camera Initialized: EZB://192.168.1.1 @ 320x240
20-02-2015 17:48 - EZ-B v4 Camera Error: System.ObjectDisposedException: Der er ikke adgang til et fjernet objekt.
Objektnavn: 'System.Net.Sockets.NetworkStream'.
ved System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
ved EZ_B.EZBv4Video.()
20-02-2015 17:48 - Camera Disabled
20-02-2015 17:48 - Camera Disabled
20-02-2015 17:48 - Camera Initialized: EZB://192.168.1.1 @ 320x240
20-02-2015 17:48 - EZ-B v4 Camera Error: System.IO.IOException:
-----------

I would say the camera is broke, ...

#10

@Jop.

Have you tried closing the project and opening up again to see if the camera initiates?