Joystick/movement Panel Question

 
#1

So I am puzzled... I have my Movement Panel working and it works fine using arrow keys ... But when I use the joystick I can see the GU lighting up in corespondece with joystick movent and the Movement Panel GU even lights up same as if I was using the arrow keys... Only difference is nothing happens with robot.. but again if I put joystick down and hit arrow keys the bot will move. ?
Note: that sometimes within same instance periodically I will get movement from bot with joystick but that is only temp.. What puzzles me the most is I could see trouble shooting it if when the joystick is used nothing happens on the GU... But everything is lighting up

#2

Okay, a bit of troubleshooting first.

Are you using a joystick control window (Add control, Misc, Joystick) as well as the Movement Panel.

If so, and you have selected the joystick from the drop down menu, is the "Joystick #1 controls Movement Panel" box checked? If you have a tick (like in the photo), this will control a Movement Panel.

User-inserted image

#3

Yes to all. When I use the joystick it moves on the EZ control screen and even lights up the Movement Panel as if I were pushing the buttons without a joystick.. Only difference is not does not move when the joystick is used

#4

A bit more troubleshooting then. Are you using the mini joystick you posted about the other day?

When in the joystick config screen, on the "Buttons" tab, press all the joystick buttons to see if they all highlight. If they do you might have to configure the forward, reverse, turn (D-pad) controls from there.

If the D-pad buttons don't highlight, here's something else. Is it a H-Bridge motor controller your controlling, or servos? If it is Servos you might have to uncheck the box (in the photo) and configure the servos in the menu.

#5

On other thing you can try I forgot to mention, is to make a note of your Movement Panel settings, delete the Movement Panel, then add and configure it again. I think someone else tried this a while back and it worked for them.

#6

I have done all of that Frown

#7

Can you post your project? It sounds like something else is stopping the movement when the joystick is used.

If the Movement Panel is responding to the joystick so show whatever the Movement Panel is set to move.

#8

Not sure if this is relevant to your situation, but I had basically the same issue with my Lynxmotion Joystick... It has a analog button on the joystick... The joystick would only drive the Movement Panel if I pressed the analog button...

#9

So i am at work and dont have my file... its on my thumb drive at home... but here is a video of the issue.

Rich I merged you ramp script to my R2 project .. and like I said it works as long as I hit the arrow keys..




#10

Are you using a UART port in your project... I just tested my joystick again and it had nothing to do with the analog button being pressed or not.... In my Movement Panel when using forward it seems my bot would not go forward if I was using either UART send or receive calls at the same time (haven't determined which one might be causing the problem)... My program calls another script within forward movement command... This script is used to monitor sensors as the bot moved forward. Inside this script is a few uart read and writes... My joystick would only move my bot forward if I removed the call to run the sensor script... However, using the keyboard and directly clicking the Movement Panel everything worked perfectly....