Looking For Some Advice From Some Smart People

 
#1

There are some pretty smart computer techs on this forum so I am looking for a bit of advice on an issue that I am having. This is not EZ-Robot related, but is a location that I can go to for some advice from people who may have some experience in this, so here it goes...

I have a raid 5 that has become corrupt. All of the drives report as good (4 drives in the array). The controller isn't able to correct the array. The device is a Seagate black armor Business Storage 4 Bay NAS. The raid 5 reports as failed.

I think I am going to have to image these drives and recover each drive but have no experience in doing this. If anyone has experience doing something like this or knows of a utility that can help in this recovery, I would greatly appreciate a direction. Before you ask, the person responsible for making sure the backups took place was not doing this part of their job, so no backup is available to restore.

Thanks in advance.

David

#2

I am hoping someone with more experience will jump in here. Most of my RAID experience is with Raid 0 and Raid 1.

With Raid 5, you need 3 of the 4 disks for it to work, so if you shut down the drive and remove one drive at a time, then replace it and remove the next. When the drive comes up on 3, the removed one is the bad drive. You should then be able to just insert a replacement and let the raid sync back up (may need to tell your raid utility to rebuild the array depending on your controller and its drivers).

Alan

#3

@d.cochran

I recommend following the steps on this site... pretty straight forward for a newb..

http://www.freeraidrecovery.com/library/raid5-recovery.aspx

If you have to follow a manual restore and need software use the freeware: "ReclaiMe Free RAID Recovery tool" link is located on the site also..

#4

Well, some more info...

Although all of the drives were reporting as good, one wasnt. The SMART test that is performed when the drives are attached to the array is a simple one. I ran a more extensive test and identified one of the drives with read errors. I have a new drive on the way in the morning. Hopefully replacing this one drive will allow the array to rebuild.

Thanks Morbeious. I actually was already about to go down that route but decided to try to find if the failure was in the controller or on one of the drives. With this discovered, I will replace this drive and hope. After that, if it doesnt work, I will follow down the process of the link above. I have to wait for a cable to arrive that will allow me to attach each drive individually to image it prior to going down that route so that hopefully I wont get to a point of no return.

Thanks all.

#5

Ok, sounds like your on the right path.. good luck my friend..

#6

There are different tools , start with ones you already have available.

http://technet.microsoft.com/en-us/library/cc938528.aspx

#7

First let's start where you went wrong. You got a Seagate drive!?!?! Trust me. Just about every drive I've used dies within a year. As for it being raid 5, I really need to start studying if I'm going to be an I.T.!

#8

At Technopro , I have built many machines in 2014 and unfortunately I had horrible luck with hard drives. I picked up several WD blue oem 1tb drives and 2 or 3 drives developed corrected sectors within 2 weeks. I ran smart, reformatted to omitted the sectors and 2 weeks later it happens agian. 2014 was a rough year for WD drives. I agree seagate has always been second to WD but recently the "desktop" and blue series enterprise I have had a 2 of 3 failure but none of the sea gates have failed. Just my experience for 2014. But p
Previously I preffered western digital.

#9

You have to understand that the tools available are limited to those that will work on an external array connected via iscsi. Also, I didn't buy anything. This is for a school system that has made many very bad decisions and I am trying to help clean up a lot of it.

As for drives, I have built many nas devices and never go with raid 5 for many reasons. I think I dealt with my first raid 5 over 20 years ago when drives were very expensive. Now, raid 5 is a very bad idea. Now raid 10 is the worst that I would setup. Unfortunately, it is the decision that someone else made and I get to clean up.

As for drive brands, I do like wd much better and they are what I use on my nas and have had very good luck with them, but the school bought seagate. Actually for pc's, I have only used Ssd ' s for about the last 5 years. My laptop has raided Ssd ' s in it for the os drive and a third ssd in it for storage, but they just don't store enough for the cost to put into a nas.

Anyway, hopefully the new drive will allow the raid to repair itself. I have a feeling that it is going to take a long time to rebuild. If it doesn't work, we will look at which tools to use to image the drives and which to use to hopefully rebuild the array. I just hope the school figures out that they need backups after this and they let me move them to linux instead of windows soon on their servers.

#10

The reason the array failed is because the drive that isn't working is being reported as good to the raid, thus it is still trying to use the drive but cant. Replacing the drive should allow the rebuild to start as the other 3 drives have been tested and are good. The raid should recover, and I can copy the data to my raid and then rebuild this array as raid 10 before returning it to them. Long week ahead I believe. There is about 6TB of data to move over a gigabit network and then back. Each move will take many hours to complete without the repair.