Odd Ezb4 Question. D14 And D15 Seem To Be Linked?

 
#1

Ok, so one of my EZB4 seems to have an odd problem... I have 2 servos connected... one on D14 and the other on D15. If I send a servo move command on D14, D15 also moves to the same position. Likewise, if I send a servo command to D15, D14 moves in parallel... I tested 2 other ezbs and they seem to work fine... Also seems to be only D14 and D15 that are affected

Fault or?

#2

Interesting. One of my EZ--B's port D15 died. I hadn't reported it yet since I have 3 others (thanks to getting 2 from Moviemaker for a bargain price).

I assume you tested all with the same project? It is possible to link multiple servos to one servo control in EZ-Builder.

Alan

#3

yep and when I swapped out ezbs everything was fine with the project that I noticed the problem on... I even cycled the power and tested it with a new project... same thing... I might try a factory reset and see if that does anything...

#4

Well, factory reset didn't work... same thing in AP mode.....

#5

Is it a new project? If not, check if you have any multi servo set up on any controls.

It could be as simple as a short between the two signal pins since they are next to each other, with it turned off is there continuity between the two signal pins?

#6

@Rich, way ahead of you... just one script in the new project... sweeping the servo from 1 to 180... both D14 and D15 sweep even though the command was issued for D14 only... Vice versa by the way, if the command is issued for D15 , D14 parallels it... I will check the continuity in a bit.... thanks.... Smile

#7

Ok... just checked the continuity... As expected there is continuity between the power pins and the ground pins, but not the signal pins of D14 and D15... Which is strange because there is also no continuality between any of the signal pins on all the ports... That is to be expected, however. None of the signal pins should have continuity... I say it's strange because I was (as Rich noted) expecting the signal pin of D14 and D15 to have continuity which would explain my problem... but it doesn't (which is just like the rest of the signal pins).... Hmmm

#8

May be a stupid question but have you rebooted your computer to see if that helps?

How about starting a new product?

Is this a new behavior with these two ports? Have they ever worked before?

Try looking close at the header pins where you plug in the cable. Can you see any solder that may be shorting the two circuits out? Try to follow the traces to see if there are any spot where the two short together. If you can't see anything then it's probably a shorted latch in a chip or it's shorted under the headder. *tired*

#9

@Dave... already tried it on another computer... besides I tried 2 other ezbs on the same computer and they work perfectly...

This was the first time I have used this particular ezb... (yes, I have bought quite a few from ez robot... Smile ) No biggie, I can live with it.... Was hoping a factory reset would have fixed it.... oh well, I can still use it with many other projects....

#10

I'm out of ideas. I don't know enough about the circuits and processor though, but I know a man who does... Hopefully Jeremie or DJ will have an idea.