Award
Congratulations DJ Sures, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Ez Builder Screen Resolution

Assistance Requested

Help Dave Schulpius with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

Dave Schulpius claims to have checked these sources:
 
#1

I'm almost embarrassed to ask this one. I've been working with Windows since the old 3.1 version back in the stone age.

Anyway, since EZ Robot redesigned the GUI of EZ Builder (when the menu bar went to black and white) everything is tiny. All controls, menus and writing is a lot smaller then it was before. More things can be placed on the work space but it's harder to see. in the early versions of EZ Builder there used to be a GUI adjustment tool bit I can't find that anymore. Also I've tried changing my screen resolution in Windows and this doesn't seem to help at all.

Any insight as to what I need to change to get everything a bit larger and in proportion in EZ Builder? I'm running Win 8.1 and EZ Builder 2014.11.18.00. Here's what it looks like. This capture doesn't really do what I'm describing justice:

User-inserted image

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

Well I found a Resize Desktop control in the general tab of the Add Control section. However it doesn't add a control. Seems deactivated.

Here's the other issue I have with this; The menu bar is screwed up in the add control section. It wont show the whole word. It cuts off words mid way and finishes it on another line.

User-inserted image

#3

@Dave Schulpius.

I can't seem to recreate the same issue you are having. Just an idea, have you tried opening a new project to see if you experience the same issue? The "Desktop Size" control does not work for me either.

#4

The "Add Controls" thing happens on all resolutions, I think. I'm running a ultra wide monitor at 2560x1080p and the same thing happens to me.

#5

@Dave.

Actually forget what I said about opening a new project. looking at the picture it looks like you have done that already.

#6

This is because Dave has changed his screen DPI between version updates - so neither no one will be able to recreate it. Dave, the EZ-Builder change to black and white icons did not create the issue you are experiencing. The DPI text was changed (wether you did it or a program that was installed did), on your PC.

The setting looks like this and can be found with Right Click on the desktop and selecting Screen Resolution..


User-inserted image

User-inserted image

#7

Thanks DJ but I already tried that. It's probably an issue with Win 8.1 and me not knowing what to adjust. *tired*

I did notice that when I hit the reduce button at the top right corner of the window and EZ Builder gets put into a smaller window box the menu bar in Add Controls goes back to normal with complete words.

#8

OK, I solved this issue and my GUI in EZ Builder looks like it did before the update. After a little Google surfing it seems I have a high-DPI display issue. Here's the link to what I found at Microsoft Spport, what it said and how I fixed it:

Microsoft Article ID: 2900023
The Problem

Code:


In order to provide an optimal experience on high-DPI displays, desktop applications have to detect the DPI of the display that is being used and then scale their graphical elements, text, and screen layout appropriately. Some applications do not implement this. Therefore, they may not look as sharp. Other applications may attempt to implement this, but may not implement it correctly, causing problems such as truncated text or incorrectly sized graphical elements.



The Fix

Code:


Disable DPI virtualization for the application. To do this, right-click the application’s shortcut and then click Properties. On the Compatibility tab, select Disable Display Scaling On High DPI Settings, and then click OK. This causes the text in the application to appear clearer. However, if the application does not correctly handle high DPI settings, this procedure may have adverse side effects such as truncated text and incorrectly sized graphical elements.



Here's my result. Yaaaa! Tongue

User-inserted image

However the Add Control section still has the menu words cut in half as shown above. Oh well, I can live with that. At least now I can see what I'm doing.