Award
Congratulations thetechguru, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Connection Questions

Assistance Requested

Help bhouston with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

bhouston claims to have checked these sources:
 
#1

I am having problems connecting to 2 EZB's at the same time. I have 2 EZBv4's on my InMoov robot. Whichever v4 I turn on first it will connect to but not the other.

I have set the static IP's for both controllers into my router (Asus RT-N12B1) and when I scan the router to see the connected clients, it will only show the first controller that was turned on. I have my router 6 ft from the controllers and my computer is connected to the router with a cable.
I am very familiar with setting up the v4's in client mode so that is not an issue.

I have in the past been able to connect to both at the same time, however, I had to shut everything down and now I can't them both to connect again. I have reset the controllers and started all over again but no luck.

Very frustrated! Thanks

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

I'll test tonight or tomorrow at the latest just to confirm nothing broke in the last release.

Alan

#3

OK, there is something strange, but it isn't in the EZ-B software.

I have 2 EZ-B's, and I have them both set with their MAC addresses reserved in my router.

One gets IP address 192.168.1.105 and the other gets 192.168.1.106.

Whichever one boots up first successfully gets its address. whichever one boots up second gets 192.168.1.2, doesn't show up in my DHCP client list (I found it using the EZ-Builder find EZ-B function) and the router log shows this set of errors:

Code:

201	Dec 5 19:05:10	DHCP	INFO	DHCPS:Send NAK
200 Dec 5 19:05:10 DHCP INFO DHCPS:Wrong Server id or request an invalid ip
199 Dec 5 19:05:10 DHCP INFO DHCPS:Recv REQUEST from 00:07:80:01:07:C8
198 Dec 5 19:05:10 DHCP INFO DHCPS:Send OFFER with ip 192.168.1.105
197 Dec 5 19:05:09 DHCP INFO DHCPS:Recv DISCOVER from 00:07:80:01:07:C8



if I reverse the startup order, it is the MAC of the other EZ-B and the address of 192.168.1.106 which is offered and refused.

My router is a TP-Link Archer C8 if that makes any difference.

#4

I did a further test. I removed the IP address reservations by MAC address, rebooted my router and tried again. Now the only limit is that my DHCP server starts with addresses starting at 100.

Again, the first EZ-B to start got an address from the DHCP server (192.168.1.105, since I have some other devices that had leases, either permanent, or that grabbed them first for 100-104), and the second one rejected the offer of 192.168.1.106 and came up as 192.168.1.2.

Going to try one more time, but setting my router to start handing out addresses at 192.168.1.2 and see how the EZ-Bs respond.

More to follow.

Alan

#5

Further testing temporarily delayed until my wife is done with the internet so I can reboot the router Smile

Alan

#6

Still not working for me either. However, I have discovered, that now that I have my computer hardwired to my router, I can connect to one v4 in Client mode and 2 other v4's in AP mode at the same time. And still be connected to the Internet.

#7

I suspect it may require a (at best) a firmware update. They are definitely not correctly negotiating DHCP, but I would need a wireless sniffer or a router with more verbose logging to see exactly what is happening, and even then, wouldn't be able to fix it, just provide more data to EZ-Robot to work with.

What I want to test though is whether there is a number range where they will except permanent address assignment or negotiate DHCP correctly and a range where they won't, which is why I need to reset the router to give out lower range IP addresses. My wife is chatting with a friend, so it may be a while (and maybe tomorrow since it has been a long day and I kind of want to go to bed soon).

Alan

#8

That's weird.... I was able to have 2 ezbs connected at once... As you guys know I have limited network knowledge so I probably accomplished this by accident... LOL.... I gave all my ezbs static IPs..... So what I did was type in manually in the connection control the IP addresses of the two ezbs and connected that way... They both stayed connected... If I use the scan tool instead to look for the second ezb it would either disconnect the first one or not even find the second one at all....

#9

It is definitely an issue with the final octet and with DHCP having gaps in available IPs vs assigned IPS.

I changed my server to start handing out addresses beginning with 2 instead of 100. Both EZ-Bs successfully negotiated DHCP with no logged errors. One got address 2, and the other got address 3. (my other running computers kept their addresses over 100 because their lease had not expired during the reboot, and two of them have permanently assigned addresses).

I then set those as the reserved addresses, and could still reboot in either order and they would keep the addresses.

However, when I assigned 5 and 6 instead, again, only the first booted would get the assigned address, and the second would fail the negotiation and would take address 2.

Setting the reservations back to 1 and 2 and it worked again, with no errors in the logs regardless of the boot order.

I also discovered they are doing some kind of interaction with each other because while testing the batteries got low on one of the devices and it kept disconnecting and reconnecting to the network. Once I unplugged it to change the batteries, the other EZ-B immediately disconnected from the network and needed to be restarted to connect.

I may try to set up Wireshark to sniff the network (not sure if any of my laptops have WNIC capable of network sniffing. I used to have one, but it was 802.11g only) just because I am curious about what interaction is occurring, but for now the simple solution is to set your router to start handing out addresses a the lowest possible octet, and reserve the lowest possible IP addresses for the EZ-Bs and they will work with reserved addresses.

Alan

#10

Oh, one other test. I reset the DHCP server to hand out unreserved addresses starting at 100 (I want it there for reasons), but left the EZ-B reservations at 2 and 3. They still successfully negotiate their reserved addresses without error.

Alan'