#1

Hi guys.

I need some advice with the Pandorabots control.

My problem is when I try to "talk" to my bot using the text input field (still training speech rec at the moment which is why I'm using the text input), the first one or two inputs are recognised and my bot responds as it should very quickly. But when I try to further speak to my bot some more using text, EZ-Builder seems to freeze for a while (cursor is non responsive & previous input is still displayed in text input field even when I type in something new). This will last for about 20 to 40 seconds then EZ builder unfreezes and starts working until the next text input where it will fteeze again.

I have tried restarting EZ-Builder and my EZ-B4 but the same thing happens. I thought it my be something to do with the Pandorabots server as I know it can be a bit flakey at the best of times, but when I opened my Pandorabot via my desktop, it responded almost instantly, and besides, this wouldn't cause a non responsive cursor.

Any help or knowledge to why this is happening? *confused*

Thanks in advance.

#2

I haven't used Pandorabot but is sounds like a resource problem within your computer or network. Have you turned off your antivirus software? Have you reserved an address in your router for your laptop and your EZB connections? Is your laptop old and underpowered? Make sure all your drivers on your laptop and in Windows are up to date.

Good Luck.

#3

Having the same issue. I've working extensively with speech recognician and pandorabot for the past 2 weeks and thought it might be my system. Kinda glad to see it wasn't . Anyone else having issues?

I have a fast 100 m/bs Internet connection and using my MacBook Pro quad core i7, 8megs ram system.

Dave does bring up a very good point with antivirus. I've had nothing but trouble with Avast! Antivirus update and everything EZB. But in client mode I dont want to shut down antivirus.

#4

@Dave Schulpius.

Thanks for your reply Dave. The laptop I'm using is no slouch. It is coming up to 2 years old, has an i5 processor, 6 gig ram, 320 gig HDD running Windows 7 64 bit, drivers are up to date, and do not have many applications installed on it. And like @fxrtst, I also have a solid 100 m/bs connection speed. Every other control I have set up or tried in EZ builder work really well and never causes the freezing issue. It's just with the Pandorabot control.

Other times I have used it (up until this week) it has been fine for the most part, although there has been times it has frozen, so I don't think my antivirus (AVG) is an issue either, and I don't see how a network connection would cause a program, or part of a program to become temporarily unresponsive.

@fxrtst.

Yeah I read one of your posts about your Avast issues a little while ago. That's a real drag. I use AVG, so far without any issues (touch wood Winky ).

#5

I wonder if it has something to do with using speech recognition and pandorabot together. I've actually noticed when it freezes the little green squiggly line representing the incoming sound stops on both speech recognition and the pandorabot windows.

Edit: I re read the post you are having issues with just typing it in. Hmmm.

#6

Using speech recognition and pandora will, at best, confuse EZ-Builder. It's like being told what to do by two people at the same time. Use one or the other. You can use script commands in Pandora, check the Pandora example.

#7

How the heck did I miss that Pandorabot already had speech recognition built into the window.....that was my biggest "doh" moment this week...and I've had several. Just killed the speech window and Pandora works great!

About a week away from being done with the project I sent you a few months back. Will post here first in a few weeks.

Thanks Rich,

Will

#8

Actually something I have noticed when EZ-Builder freezes after a text input to the Pandorabot control, is that where I said that the cursor becomes unresponsive, that is not entirely accurate. I found out
it does infact move, but under the EZ-Builder desktop so nothing on EZ-Builder can be selected until it unfreezes and the cursor appears back on top of the desktop.

I noticed this when I opened my task manager and found that the cursor was visible and active on my system task bar and on the task manager. Move the cursor over to EZ-Builder and it would now appear on top of the desktop, but still unable to select any of the tabs or controls.

This is becoming a real pain now as anyone trying have a conversation with my bot gets frustrated with waiting for almost a minute for a response, and is almost pointless using. Any help or suggestions with this? *stress*

#9

Yes exactly what I noticed today. I get the same results with the rest of the EZB, unresponsive. I'm have the same issue but instead of typing I'm using the speech recognition. Seems it doesn't matter in the way data is input, the results are the same with the freezing. Almost unusable.

#10

@fxrtst I'm also having the exact same issue with "Pandorabot", The EZ-Builder becomes unresponsive at random intervals for lengthy periods. Best results occur when "Pandorabot" is the only item in the project. Same results using EZ-Builder on three different PCs.

Another odd issue is the actual speech recognition. Most of my commands issued in "Speech Recognition" are understood, ie. this function works very well. When using the "Pandorabot" it translates my Aussie English into the strangest, sometimes very amusing phrases! The same results occur using different PCs and a variety of microphones. Maybe I need to speak "Canadian"?

Also I'm still not having any luck changing the voice type using the "Speech Synthesis Settings" even though the default voice is changed under the windows settings