Award
Congratulations DJ Sures, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

No Speak

Assistance Requested

Help bhouston with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

bhouston claims to have checked these sources:
 
#1

For some reason I can't get any Speech to play. In a script for example I have;
Sayezb("speak like a human"). However when I run the script I get no sound It doesn't "Say it". I have the "Speech Settings" setup. The speaker is working, I hear it on startup.

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

Stupid question... are you connected to the ezb when you run your script (a solid blue or green LED on your ezb4)? Does this work... Say("I am a human"Winky play through your PC speakers?

#3

Yes I am connected to the EZB and the other parts of the script run OK. No speak thru the EZB or the PC. I want it to play thru the EZB

#4

Hmmm then it's not a faulty ezb4... Speech doesn't seem to be loaded.. Has speech ever worked out of the ezb speaker or your PC speakers before? Try the easy things first... save your file, close ez builder and reboot your PC if necessary... Then try again...

#5

Are you getting any messages in the DEBUG window of EZ-Builder? It will pop up with messages. Look in it - copy and paste to us as well.

#6

I'm not getting any error messages. I have set this project up on and I am connected to Board 1. Is there a setting somewhere to send everything to Board 1? I have the Auto Position set to that board.

#7

audio only comes out of Board #0. Why are you using Board #1? What is connected to Board #0?

#8

Oh Man... I was just about to ask the same question, but I was hesitant as figured it probably wouldn't have any relevance on why the audio wasn't working.... Something else I leaned today... Thanks DJ....

Another good example showing how important it is to give as much detail about a problem you are (I mean everyone) having... Sometimes the answer is in the smallest detail....

#9

Well, there you go! Did not know that audio only comes out of Board #0. Thanks DJ and Richard, I switched everything out to Board #0 and the audio is working.
Dilemma Resolved !

#10

yay! High fives Grin

Board #0 is the first board and supports the most features. The other boards are used for adding additional servos and connectivity - however the majority of features default to Board #0