Award
Congratulations JustinRatliff, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Assistance Requested

Help fxrtst with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

fxrtst claims to have checked these sources:
 
#1

Hello,

Back after some absence. I'm having trouble with my EZBv4 and getting sound servo to work with the latest version on EZB Builder. Sound servo (PC) crashes the EZB software. with an exception error. I tried on two different laptops and got same error message and crash. If I choose the sound servo (EZB) I get an error message at the bottom of the screen that says sound object is being used elsewhere.I've rebooted the machine thinking that something else was using it. Same thing.

I'm trying to talk live into the microphone and have a servo controlled by my voice. At this point Id be happy to get an mp3 or wav to work with sound servo. Any suggestions?

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

Are you using the Movement Panel also? If so, make sure that the servo you are using for your sound servo isn't specified in there. Also, make sure that you don't have any servos added without specifying which port they are on.

I will dig up a thread from a few days back for you.

#3
#4

I do have to say that DJ thought it was the computer which is entirely possible and it could be the sound card having the issue. It could also have to do with the software and an update. I don't know for sure if this fixed b.houstons situation or not, but just wanted to share.

I hope it helps.

#5

Thanks I will give it a look thru!

#6

...hmmm nope. I had the same computer with EZBv3 connected up several months ago and had no problem running wav files and getting the response i was looking for. I no longer have that ability. The hardware has not changed in this computer, I have one servo connected up to sound servo EZB (because it the only one that will not crash the software.), and nothing else open oin a clean new project. I keep getting the error that its in use elsewhere. Any other ideas, how to get it to just work with one wav file and get the servo to move with just the one .wav file.

This pains me when something changes that worked before.

#7

Have you updated ez builder to the latest version? 9.16?

#8

You could try to upload it, let me open it and see if I get the same error if you want.

#9

I've managed to get get it to work with Soundboard and a prerecorded .wav file on the EZB but not the PC. I've also managed to record my voice with EZB microphone and again was able to use that, again using the EZB Soundboard. I want to be able to control the servo live with a microphone or have the ability to use speech synthesis, Pandorabot, etc to make it move. Any ideas on that?

#10

Sorry, I actually have never used this control. Someone else is going to have to chime in on it. I am interested in this but have no experience at it.