Voice Recognition In Acer Aspire Switch 10

 
#1

I bought a Acer Aspire Switch 10 (Z3745, 64 GB, 2GB RAM) and I tried to run my Robot setup in EZ-Builder. Everything worked OK except for Speech recognition. In my For example The Lenovo Yoga, i5, 8GB RAM the same robot setup in EZ-Builder works OK. However speech recognition for Acer Switch 10 in MS Windows 8.1 works without any problem (commands - open apps, close apps, Scroll left...etc.), but Ez builder not. What am I doing wrong? Thanks for your help.

#2

Does the Debug window show anything wrong?

#3

did you turn on speech under windows?

did you train windows for speech ?

if you did not, then do that, before getting EZ-Builder to work.

j

#4

To Rich: Nothing
To jdebay: Yes and yes, I did it. Windows work correctly.

#5

What does the debug window show when add speech recognition?

It should show something like this;

Code:


EZB 0:
EZB 1:
EZB 2:
EZB 3:
EZB 4:
07/09/2014 07:05 PM - TCP Server stopped
07/09/2014 07:05 PM - TCP Server stopped
07/09/2014 07:05 PM - TCP Server stopped
07/09/2014 07:05 PM - TCP Server stopped
07/09/2014 07:05 PM - TCP Server stopped
07/09/2014 07:06 PM - Speech Recognition Culture: en-US
07/09/2014 07:06 PM - Loaded speech recognition successfully



The speech recognition control works directly with Windows. If it is set up correctly in Windows it will work in EZ-Builder.

When you say it doesn't work, can you elaborate? Does it not load? Does it freeze EZ-Builder? Does it just not detect any speech? By "not work" it could be a number of things.

#6

To Rich: Yes, but window with Speech recognition doesnot show anything.

Debug window:
7. 9. 2014 21:42 - TCP Server stopped
7. 9. 2014 21:42 - Speech Recognition Culture: en-US
7. 9. 2014 21:42 - Loaded speech recognition successfully

#7

@Donesvarc could you give us a screen shot of the Speech recognition window?

Is it possible that your mic is muted?

#8

To Jeremie: Yes, I will make it. But recognition in Windows is functional. If I speak into Ez.Builder waves are indicated ?

#9

If that's the case it sounds like it is working, it's just not detecting any of the defined voice commands.

#10

That's correct, as soon as you add the speech recognition control you should be able to speak loudly and see the waves in the top right bar of the speech recognition window. If you don't see any waves your mic might be muted or maybe the on-board microphone drivers need to be updated.