Award
Congratulations DJ Sures, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Camera Video With Ezb 3

Assistance Requested

Help rb550f with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

rb550f claims to have checked these sources:
 
#1

I have a wireless video camera that has a receiver on usb port.I am using EZB version3 .Camera comes up great with video software that came with camera,but i get no image when i select OEM video device from camera device list. Realtime video no image .Tried different resolutions no video when i hit start?

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

rb550f,
Is there some way you can remove the software driver that came with your camera and let windows find its native driver when you plug in to the USB?
I have heard that some drivers can cause problems.
Steve S

#3

Are there any messages in the debug window when you press the START button on the camera?

#4

at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
at  .(IAMStreamConfig , String , Object )
at  .(Size )
at EZ_B.Camera.StartCamera(ValuePair videoCaptureDevice, Control processedPreviewControl, Control realtimePreviewControl, Int32 captureWidth, Int32 captureHeight). Resolution: 320x240

#5

Windows 7 not able to install without oem driver.

#6

Sorry, press the COPY button on the debug window to get the full message. It appears the default native resolutions are not supported on that camera - but I can't be certain without the full message.

It could be a camera from some strange manufacture for PAL resolutions or something strange Smile

#7

Here is the debug statement copy.
6/10/2014 4:24 PM - Camera Disabled
6/10/2014 4:24 PM - Camera Initialized: Chicony USB 2.0 Camera @ 320x240
6/10/2014 4:24 PM - Camera Disabled

6/10/2014 4:25 PM - Error Initializing Camera: System.Runtime.InteropServices.COMException (0x80004005): Error HRESULT E_FAIL has been returned from a call to a COM component.
at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
at  .(IAMStreamConfig , String , Object )
at  .(Size )
at EZ_B.Camera.StartCamera(ValuePair videoCaptureDevice, Control processedPreviewControl, Control realtimePreviewControl, Int32 captureWidth, Int32 captureHeight). Resolution: 320x240

I started with camera on laptop..works..Then i tried OEM video device camera and tha is the statement i copied from debug

#8

I still need assitance on getting video for this camera?

#9

Sorry, it appears that camera is not compatible with standard video resolutions - EZ-Builder supports only standard video resolutions

#10

So what are the standard resolutions?