Award
Congratulations thetechguru, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Connecting To Two V4 Ezb's

Assistance Requested

Help Dave Schulpius with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

Dave Schulpius claims to have checked these sources:
 
#1

First question and problem: I think the intent is to be able to connect up to 5 EZB's through EZ Builder. However I've hit a wall trying to connect EZ Builder to two V4 EZB's when they are in AP (Access Point) mode. Using my laptop I've followed directions and connected EZ Builder to the first V4 after establishing a wireless connection through the "Wireless Network Connection" icon on my Win 7 Taskbar. Then when I try to connect wirelessly to the second V4 EZB I lose the wireless connection to the first. My laptop will only let me have more then one wireless connection at a time. What am I missing here?

Second question and problem: With both V4's in Client mode and the Green light blinking (the voice says she's attached to my network), I can only have one EZB powered up at a time and have a successful search of my router for a IP address. If both are powered up and attached to the network EZ Builder cant find an address. Is this normal? I've watched the tutorial several times.

Third Problem: For two nights now after the laptop and robot are powered down the second EZB entry in EZ Builder will not connect to the second EZB board. I have to push the network reset button on EZB and redo the IP search in client mode.

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

I can only help with the first question. At least one of the ez-b's must be in client mode. You can use the AP on one as the master for both your computer and the secind ez-b, or you can connect both ez-b's as clients to your network and your computer to the same network. To connect to two ez-b's in ap mode, you would need two wireless cards in your computer, and even that can get tricky.

Alan

#3

I can't check this but I believe the second EZ-B can connect to the first EZ-B's network much like your PC does.

First set up the first EZ-B for AP mode (default) and set any passwords, change the SSID etc.

Next connect to the second EZ-B, log in to the config through your web browser and set it to connect in client mode to the first EZ-B's SSID.

Now connect the PC to the first EZ-B's WiFi
In EZ-Builder, the first EZ-B should always be 192.168.1.1:23
The second EZ-B could be anything in the 192.168.1.x range, scan for it and it should come up.

Sorry it's a bit brief, just writing this before heading off to work.

#4

thanks rich. I remember now reading this somewhere. I'll give it a try to see if I can get it to work.

However my preferred method of connection at this time is to have both connected in client mode to my home network
Connected like this I have noticed some lag in response. Most noticeable in sending sound files to the EZB speaker. At times several seconds will pass before EZB will respond. Most times response time is right away. I wonder if its due to heavy traffic of other devices on my home network?

Also an update; I had both V4 ezb's Connected to EZ Builder in client mode and for the third day now after everything sitting powered off overnight (except the network) I can't connect the second EZB to EZ builder. Any ideas on this. Seems to be a pattern. BTW, I did power cycle the ezb's after setup to client mode.

#5

I've had no lag issues with my EZ-B, I was genuinely shocked at how responsive it is, as can probably be heard in my unboxing/first look videos. That said, I do have very strong, fast WiFi signal and few other WiFi devices connected to it. Network traffic or even lower signal strength may affect it. My router tells me the connection speeds and quality however it does run DD-WRT firmware (IMO the best firmware for a router), your router may not show that information.

The first issue that comes to mind is a problem with the IP addresses or the DHCP service. I have my router specify fixed IP addresses based on the MAC address of the NIC connecting, I need this for my home network to function correctly. Again, this may not be available in your router.

The other thing to check is any MAC filters you have on. Is it possible you added the one EZ-B to the MAC filter enable list but forgot the second or mistyped the second?

Provided your SSID and network key are entered correctly (and remember, they are case sensitive) and the MAC filters are off or set correctly then I can't see any other reason for it other than an issue with the DHCP of your router.

If the first EZ-B is not connected does the second one connect?

Have you tried rebooting your router?

Some routers will give you hell. I know if I go to my brothers house and log on to his WiFi with my phone and tablet my phone will connect fine but my tablet is given the IP of 169.x.x.x which isn't what it should be. My sister in law's laptop often boots up and gets given a 169.x.x.x IP too. This is due to the router they have. Sometimes it'll let you on but others it wont.

If you let me know the make/model of your router I may be able to find some info on what services are available on it and guide you through setting up some MAC based static IPs.

#6

I'm sure it's something with my router or other devices on the network. I had considdered setting up a Static IP address for each EZB but not sure how to do it or even if my router will do it. I looked in it's setup web page but only thing I could find was a way to sit my the main IP Supplier's address as a static number (I think). I know just enough about all this stuff to make myself dangerous. *eek* Thanks for the offer of guideance.

I'll ahve to wait till later to get the router make and model.

I do know this; the only way I could get EZ Builder to find a number to assign to EZB #2 when doing an IP serch was to power down the first EZB. #1 EZB had already been installed and connected in Cliant mode. Only then with EZB #1 powered down would EZ Builder find a number and I could connect both units. I would then power cycle as advised. Then after being powered off for many hours EZB #2 can not connect. I did try a short powerdown of an hour or so and I did have success with both units connection. BYW, both EZB's would have the green light flashing and the voice would tell me that she was connected to my network uopn powerup.

#7

I have a suspicion that the voice may tell you that if your router assigns the 169.x.x.x IP address as, in theory it's connected to a network.

The normal way to assign static IP addresses is on the PC in the network options however you don't have this option with the V4. Some routers can, as previously mentioned assign IPs based on MAC address but some can't. My current router is the first and only router I've owned which can.

Another option may be (however I am unsure) to use an Access Point. I haven't used one for close to 10 years now but I am pretty sure they can be set up to use their own DHCP service and assign IPs to devices connected to them rather than the router itself. I am sure the one I used would assign an IP and it would be in the correct range (i.e. router IP of 192.168.1.1, Access Point IP 192.168.1.100, WiFi devices connected to the Access Point assigned 192.168.1.150-192.168.1.169). If nothing else works I'll see what info I can dig up on Access Points however their popularity has probably shot down now all routers have WiFi capabilities (I used mine as my router didn't).

#8

The AP methoid you discrib sounds like it may add a layer of comlpaction I would rather avoid if possable.

#9

Now that I am thinking about it I do remember seeing a EZB in the filter section of the router. I didnt put it there that I can remeber an useing the old V3 and bluetooth I dont think I did it in the past. I'll have to take a look at that when I get home.

#10

The answers you are looking for...

1) Like all wireless devices, having them too close will cause radio interference. The EZ-B's should not be within a foot or so from each other. It's not a distance that I can just tell you. It's a variable distance that depends lots of stuff... it even depends on humidity and temperature believe it or not, which is the source of all radio and static interference. The main reason of course is the electrical radio hardware in the EZ-B.

2) When you are at home, connecting multiple EZ-Bs to your network is the way to go. If you are experiencing performance issues, that is to be expected with low signal strength. If your EZ-B is inside a metal robot, the signal strength will be much less than what your laptop reports. Keep in mind that your EZ-B is a Wi-Fi device and will therefore suffer from Wi-Fi related requirements.

Keep in mind that the EZ-B uses all available bandwidth. It is bandwidth hungry! There are millions of things happening per second to make it as awesome as it is - specifically with the camera and audio. The communication/audio protocol uses 3.3 mbps and the camera video also uses an additional 3.3 mbps... Yeah, she's bandwidth hungry! But hey, it's 2014 right? We're pushing the limits of technology to make 2015 a year full of EZ-Robots

3) If you are out at a show - the best way to connect multiple EZ-B's is by putting your laptop in Access Point Mode. That is quite a simple process and it can be turned on and off - so it doesn't require a lot of configuration before heading to a conference or walking your robot down the street. Google will be your friend on how to setup your OS as a Wi-Fi access point Smile