Award
Congratulations Dave Schulpius, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Ping Dave, Need Help On The Kangaroo X2 Setup.

Assistance Requested

Help Richard R with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

Richard R claims to have checked these sources:
 
#1

So I got my Kangaroo x2 board and I am trying to test it using basic serial command... I have been using this sample code (below)... I think I have the dip switches right (maybe not), but all the motor does is spin at about half speed... and nothing sent from the EZb does anything... See the picture to see if I have everything hooked up right... not sure what I am doing wrong... Can't even stop the motor from spinning... As soon as I plug in the Kangaroo and add power, the motors begin to move? I haven't read the entire Kangaroo manual yet, so maybe I am missing something... The sabertooth 2 x 12 is ver 1 that I bought 2 years ago... Maybe I need a newer one?

Dip switchs on the Kangaroo is 1=on the rest off... The Sabertooth has 1,3,5,6 on and 2,4 off

SendSerial(D0, 9600, "D,p2450 s800", 0x0d, 0x0a)
SendSerial(D0, 9600, "D,p3675 s800", 0x0d, 0x0a)
SendSerial(D0, 9600, "D,p1225 s800", 0x0d, 0x0a)

D0=EZ Robot Port
9600=Baud
D=both Motor Channel
Pxxxx=Position
sxxx=Speed
0x0d=Return Key *
0x0a=New Line*
User-inserted image

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

I just had time to take a quick look at your picture. I think you have the dip switch is said wrong on the saber tooth. I believe that switches 1 and 2 need to be on and all the rest need to be off. Double check the manual to be sure. I don't have right now to check the rest your cold. I will take peak later. Sorry.

#3

Thanks Dave... Tried that, but as soon as I connect power the motor spins (now at full speed)... the serial commands from the ezb do nothing... I will read over the manual... If I take off the kangaroo (I have 2 kangaroos both do the same thing) the sabertooth works perfectly responding to serial commands as expected..

Richard

#4

Sorry about last post. I sounded like a caveman.

Still have little time till later but without looking this over closer I think you may still have the dips set wrong. If you have it set up as a closed loop system you need to have a feedback device like a pot hooked up to a motor and jangaroo and ready. If not you may have a runaway issue. Did you do the training mode yet?

#5

No training mode yet... probably my problem I'll assume...

#6

Looks like I need to print out the manual and have a good read... You're right Dave this thing is really convoluted to learn and use...


Cheers
Richard

#7

Looking over my last posts I see I really need to check what my smart phone is writing as I speak before I send it out. *blush*

I found that you need to have everything hooked up and ready to go first before you can get this to work. At the very least you need your motor, Control signal and a feedback device like a pot or encoder attached before you power up. The first time I powered up I had a runaway also. This is from the manual:

Code:


Kangaroo x2 requires at minimum one signal input, one feedback input, one motor and must be connected to a Sabertooth or SyRen motor driver to operate.

Kangaroo x2 requires a sensor telling the controller where the device is and how fast it is going. This sensor signal is called feedback. Kangaroo supports two different kinds of sensors, quadrature encoders and potentiometers.



Once you have all that set and all your dips set properly on both the Kangaroo and the Sabertooth only then can you try a Autotune. The directions in the manual to start a tune are confusing also. There are several tuning modes,

1. Teach Tune - Move the mechanism to define the tuning range (one LED Blink)
2 - Limit Switch Tune, Normally closed limit switches define the tuning and operating range (2 LED Blinks)
3. Crash Limit Tune - Physical stops define the tuning and operating range (3 LED Blinks)
4. Input Calibrate Mode - This mode calibrates the R/C or analog inputs. (4 LED Blinks)

Hold the small button down for a couple seconds until the LED starts to blink slowly one blink at a time. The number of blinks correspond to what mode you want. To get to the next tune mode hold the button down again for a couple seconds. then it will start to blink slowly two blinks, exc, exc,

Now when you get to the Autotune you want push the button once quickly and it will start to blink quickly corresponding to the tune your in. like 2 fast blinks, 2 fast blinks, 2 fact blinks.........

To start the tune push the button quickly again and the led will light steady for a second then start blinking quicker like a count down. Get out of the way because the Autotune will start moving the motor back and forth for a few minutes. Kinda fun to watch really.

If the tune is successful the motor will stop and the led will be lit steady. Power cycle the unit before you start to try to use it.

Hope that is clear. good luck and let me know how it works.

This evening I also found that in velocity mode the Kangaroo wont accept servo commands from EZB. Don't know if it's my set up or the way EZB sends out the servo pulse. *confused*

Dave

#8

Thanks a million Dave... I am going to put it aside for now as I am too tired and busy to have a hard look at this... I'll take another crack at it in a few days or so...

Again, thanks for your help...
Richard

#9

Hope you can keep interest in this and can get it to work for you. It would be nice to have someone else working on this to swap ideas and results. I'm sure you'll get it running to your liking and all will be well with my project once we get the V4 EZB with two way serial communication and a good script.