No Power On Ezb

 
#1

Tried the troubleshooting tips, I'm good on everything except I'm not getting 3.3 vdc on the power pins. What could it be? No lights on both the blue LED and the Bluetooth LED. Regulators are fine too. I tried to unplug and re-pug the chip too.

Thanks in advance.

#2

Hello @Doombot,

If the Red LED on the Bluetooth module is not blinking that means that either the logic 5V regulator (MIC23900) beside the blue LED is not working or the Bluetooth module is damaged. I'm assuming that if your chip and bluetooth module both aren't working than it's the 5V regulator that's either damaged or the input fuse is blown. I would check the status of the fuse between the two regulators as your first step.

#3

Might be the fuse then. I tried switching the BT module to working v3 and it works.
If it's the fuse how do I reset/replace it?

#4

Ok I pulled the fuse out its fine

#5

Awesome so the fuse is a standard 5A Mini Blade fuse for cars, you should be able to find a replacement at most Automotive parts stores. 7.5A will do as well. 10A can do in a pinch but it's a little high.

#6

Ok both the regulators seem fine.

#7

Also great to hear, that means that there was a short circuit that happened somewhere and the fuse did it's job to protect the circuit. Smile

#8

Ok I don't think I'm being clear enough.
The fuse is fine.
The regulators are also working fine, I think.
Checking the voltages on the caps, the only thing I'm not getting is the 3.3 vdc, I'm only getting 1.5 vdc.

Could this be a regulator issue?

#9

Hmmm, do you mean that the 3.3V regulator isn't working? This regulator isn't hooked up to anything it is just there for Arduino Shield compatibility you could just cut it right off the board or replace it. The chip runs off the 5V regulated voltage from the MIC23900.

Do you have the blue and red LEDs working now?

#10

cut off the 3.3v regulator.
Still no LEDs.