Award
Congratulations Rich, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Voice Recognition Question

Assistance Requested

Help fredebec with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

fredebec claims to have checked these sources:
 
#1

Hello everyone,

It's been a while since I tried my wall-e project. I have now a new windows system (windows 8.1) and the last version of EZ-Builder. It appears that voice recognition don't work anymore:
When I launch the project, i have this error message : "Voice recogition was not able to start. There is either no listening device or the your operating system is not supported". I made a new fresh project and had the same message when i tried to add speech recognition (see screenshot).
User-inserted image
Microphone is setup and windows voice recognition is configured (and works ok: i can control windows by voice commands).
I tried to put the system language in US (even if it has never been a problem before), with no success.
So now i am out of options and any help is welcome.

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

You need to set the language in Windows Speech Recognition to US for it to work. When you say you had no success with that, how come? What happened? What stopped you?

#3

is this the setting?
User-inserted image

#4

@Rich, I have try to put all the language settings of windows to US but still have the same error message.
However, in the voice recognition language setting, i have only UK and French language available... Is there a way to download the US language?
The strange thing is that I have always used the French settings before, when i was under Windows seven... so i don't know why i have now this error message *confused*

#5

Ok, I have successfully download the US language pack and if I put every language settings to US, including voice recognition, it works now in EZ-Builder. So it seems that my problem is solved... Thanks to Rich.

Still, one question remains: why were I able to use voice recognition in french before ? Maybe I should try to reinstall windows 7 and see what happens....

#6

My PC is set to UK for everything as I need it for other applications. That said, EZ-Builder doesn't error when I try to add SR, but I haven't yet been successful in getting a voice command to work - this may be due to my current mic set up or may be something else, I just thought I would mention it.

Glad it's solved. I can only imagine something in the EZ-Builder code has changed. Which version were you running where french worked?