Award
Congratulations thetechguru, for answering the question and has received an EZ-Credit award! Share what you have learned and create a tutorial to help others by clicking here.

Ez-builder Http Server Control

Assistance Requested

Help Richard R with their question and receive $10 of EZ-Credit to get more robots and parts from our store. The following information was provided about their previous efforts searching tutorials for a resolution.

Richard R claims to have checked these sources:
 
#1

My project I am working is remote presence robot controlled obviously remotely... I think I am missing something, though because I can only get my robot and camera to operate if I am actually on my own wifi network... I tested it over my girlfriends wifi network at her work (using her android tablet), but she kept getting page not found error when she tries to log on to our home network... Am I missing something that I need to do different using other wifi networks away from home or would it be because her work's firewall (or even mine) won't allow remote access to our home network? What do I need to get remote access to my robot and camera?

Hope this makes sense and thanks
R

I have found a few conversations, tutorials and activities that may help with your question. Take a look at these links. I've sorted them by what I believe to be most relevant but that is not always the case as I'm still learning.


Also, consider reviewing the Learn section for informative lessons and activities. Check it out!


#2

When I add the HTTP Server control it lists 2 IP addresses. One for my local network. 192.168.x.x And a second one that is my computers address on my providers network. 24.52.x.x You should be able to connect to the local one (192) fine from home but you probably need to set an exception in your firewall to access your robot from a remote location. That would use the 2nd IP address. In my case the 24.52.x.x It's been a while since I've messed with it but I remember it running fine right out of the gate.

Now I have to ask, only because I've made this mistake myself, are you sure the server was started when you tried from your GF's office? Also a lot of offices have restricted traffic so that may be a problem as well. I'm willing to bet the real issue is your GF's work internet restrictions. Next time you get chance try from a McDonald's or Tim Horton's or some place like that that offers free wifi. That will use the 2nd IP not the 192.168.x.x

Also if you have DHCP enabled, that 2nd IP address may have changed due to a computer, router, modem or other reboot. So next time you try make sure that you have the right IP address. This also happened to me. I had a project all set up and the page bookmarked in my browser then page not found errors. That's when I noticed the IP changed and I was now going to the wrong IP address. I now use a static IP for my EZB-PC on the local network. You'll still need to keep an eye on that second IP though as it comes from your provider so you don't have much control over it.

I'm going to be out and about in a little bit here. (To a Tim Horton's even) I'll leave it running and try to connect from my phone from there.

I just check my router and the only thing I have set up is port forwarding for port 80 (the HTTP port) but it's not for my ez-robot computer but another one in my house so I'm not sure if that even matters. I just logged in from my phone with both IP addresses. I'll check it when I'm out and let you know what happens. I've never tried to connect from a truly remote location so now you've got me curious. Winky

#3

Yes, the server was/is started... and like I said it works perfect on my own network (using the first IP address 192 and logging in as admin)... I will try it on another open network like Tim Hortons or Starbucks.... Thanks Antron

#4

You not only need to use the public IP address, but you need to forward the HTTP port to your robot's internal IP address in your home router. The default port is 80, but some internet providers will block inbound port 80 to protect you from hacking attacks and to prevent you from running web servers at home. For the first reason, it is a good idea to use a different port anyway. You can set the port in EZ-Builder. Port forwarding is different for every router, but you can learn how in your router's manual or just google your router's make and model and the words "port forwarding" and you will find instructions.

Then to connect, you will need to include the port in the URL (sample - not a real address http://24.64.211.14:8190/ )

Your external IP address can change at any time unless you are paying extra for a static address, but usually it will be when your router reboots. You can sign up for a service like DynDNS that will update a host name with your current public IP address. You will need to run a client on your computer to keep the service updated every time your IP address changes. The your url would look like http://rryerson.dyndns.com:8190

Alan

#5

You will need to check the settings on your router to port forward the correct port to the correct internal IP address.

Every router is different but it should say in the instructions or on the admin pages of the router.

#6

Thanks Alan, Antron and Rich... I'll have to dig into this...

Cheers
R

#7

They are correct. You will have to use port forwarding. My last test gave me a false positive and I had to reconfigure port forwarding for the correct computer. I can't access through my public IP but that's because of the set up I have. My provider gave me a crappy router/modem combo so I turned the WiFi off on it and am using a separate router so I'm going to have to make some changes to that router as well before I can expect it to work.

Good luck. I hope you get it all figured out soon. When you do please post your process and results. Smile

#8

Ok, I just logged into my routers gateway setup... (Firewall settings and port forwarding etc)... Before I touch anything that I shouldn't be touching (like opening my network for attack)... Is there settings I should not be screwing with? The instructions I read on the internet states I need to disable my firewall first then select port forwarding as the next step... Since I know nothing about what I am doing I am not sure I am comfortable dropping my firewall... I think I better do some more research here...

#9

Probably wise. Most routers can have firewall and port forwarding coexist. In fact, in many cases the port forwarding is one of the firewall rules (although the user interface doesn't describe it that way, it is what it is doing on the inside).

Alan

#10

Thanks for your help Alan...and everyone else... I'll figure it out and post back here later...

R